summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2002-07-09 18:11:50 +0000
committerJohn Millaway <john43@users.sourceforge.net>2002-07-09 18:11:50 +0000
commit3cfbabfe5dea37286ed9fc7e697493e832affbbc (patch)
tree06e0f1a122df88875f50598a5fb7d538b7f142cd /configure.in
parent4fff5ecd99ef799c3d01672a83b997ebc85e71fb (diff)
Replaced obsolete macros in configure.in.
Modified create-test to handle the above changes in configure.in. Added support for <stdbool.h>.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 467024d..1daa526 100644
--- a/configure.in
+++ b/configure.in
@@ -31,18 +31,18 @@ AM_CONFIG_HEADER(config.h:conf.in)
AC_PROG_YACC
AC_CHECK_PROG(BISON, bison, bison)
AM_PROG_LEX
-AC_LN_S
+AC_PROG_LN_S
AC_PROG_CC
AC_PROG_RANLIB
AC_PATH_PROG(HELP2MAN, help2man, $srcdir/missing)
-AC_CONST
+AC_C_CONST
AC_TYPE_SIZE_T
AC_HEADER_STDC
-AC_HAVE_HEADERS(string.h malloc.h sys/types.h unistd.h)
+AC_CHECK_HEADERS(string.h malloc.h sys/types.h unistd.h stdbool.h)
-AC_OUTPUT(
+AC_CONFIG_FILES(
Makefile
examples/Makefile
examples/fastwc/Makefile
@@ -75,4 +75,6 @@ tests/test-lineno-nr/Makefile
tests/test-lineno-r/Makefile
tests/test-debug-r/Makefile
tests/test-debug-nr/Makefile
+dnl --new-test-here-- This line is processed by tests/create-test.
)
+AC_OUTPUT