summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-04-09 00:42:23 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-04-11 11:08:42 -0700
commit7db3bf58a48b9952fac1fd907fb23f5d257ed7ec (patch)
tree754a1cb09b3d8bcdb8a59f134a8f2cde9ca4813c /debian/rules
parent995114eb4b550e2db30a10423b26327e3337582d (diff)
[master]: New upstream version.
* internationalization: added support for various languages. Fix make install target to not fail when the flex++ program is already installed. various portability fixes that quiet compiler warnings on 64-bit hosts. numerous bug fixes. * Moved to a new dh based build system. Also moved to a 3.0 source format, using debcherry. * Bug fix: "cross build support", thanks to Eleanor Chen. We have moved to a standard dh based build, so we should not have this issue any more. (Closes: #719955). * Bug fix: "examples not included into binary packages", thanks to Carl Fürstenberg. Examples are in this version. (Closes: #560387). * Bug fix: "new upstream release 2.5.37", thanks to Peter Eisentraut (Closes: #729759). * Bug fix: "flex, new release available for download", thanks to Gianfranco Costamagna (Closes: #736345). * Bug fix: "please mark flex as Multi-Arch: allowed", thanks to Steve Langasek. Redid the patch to work with dh. (Closes: #611230). * Updating to a new build system means that the changes made to the build system in the NMU are not needed, dh does the right thing. * The new upstream release added the prototypes in re-entrant mode, so we are no longer carrying those patches. Signed-off-by: Manoj Srivastava <srivasta@golden-gryphon.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules76
1 files changed, 76 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1e411ce
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,76 @@
+#!/usr/bin/make -f
+# Uncomment this to turn on verbose mode.
+# export DH_VERBOSE=1
+package:=flex
+SRCTOP:= $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi)
+INSTALL = install
+ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+install_file = $(INSTALL) -p -o root -g root -m 644
+install_program = $(INSTALL) -p -o root -g root -m 755
+install_script = $(INSTALL) -p -o root -g root -m 755
+make_directory = $(INSTALL) -p -d -o root -g root -m 755
+
+DPKG_ARCH := dpkg-architecture
+export DEB_HOST_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_HOST_MULTIARCH)
+
+%:
+ dh $@ --with autoreconf
+
+override_dh_auto_configure:
+ if ! which flex >/dev/null 2>&1; then \
+ if [ -e debian/scan.l.md5sum ] && \
+ [ "`md5sum scan.l`" = "`cat debian/scan.l.md5sum`" ]; then \
+ if [ scan.l -nt scan.c ]; then \
+ echo "scan.l newer than scan.c"; \
+ fi; \
+ touch scan.c; \
+ fi; \
+ fi
+ ac_cv_lib_util_getloadavg=no dh_auto_configure -- \
+ --prefix=$(PREFIX) $(confflags)
+
+override_dh_install:
+ test ! -d debian/tmp/lib/$(DEB_HOST_MULTIARCH) || \
+ find debian/tmp/lib/$(DEB_HOST_MULTIARCH) -type f \
+ -name \*.la -exec rm {} \;
+ dh_install
+ $(make_directory) debian/libfl-dev/usr/lib
+ sed -e 's,#DEB_HOST_MULTIARCH#,$(DEB_HOST_MULTIARCH),' \
+ debian/libfl.shared_object > debian/libfl-dev/usr/lib/$(DEB_HOST_MULTIARCH)/libfl.so
+ dh_link usr/lib/$(DEB_HOST_MULTIARCH)/libfl.a usr/lib/$(DEB_HOST_MULTIARCH)/libl.a
+ dh_link usr/bin/flex usr/bin/lex
+
+
+override_dh_installdocs:
+ dh_installdocs
+ifneq (,$(filter flex-doc, $(shell dh_listpackages)))
+ mv debian/flex-doc/usr/share/doc/flex-doc/flex.html debian/flex-doc/usr/share/doc/flex-doc/html
+endif
+
+override_dh_installexamples:
+ dh_installexamples
+ifneq (,$(filter flex, $(shell dh_listpackages)))
+ mv debian/flex/usr/share/doc/flex/examples/examples debian/flex/usr/share/doc/flex/tmp
+ rmdir debian/flex/usr/share/doc/flex/examples
+ mv debian/flex/usr/share/doc/flex/tmp debian/flex/usr/share/doc/flex/examples
+ test ! -f debian/flex/usr/share/doc/flex/COPYING || rm -f debian/flex/usr/share/doc/flex/COPYING
+endif
+
+override_dh_auto_build:
+ dh_auto_build
+ $(MAKE) -C doc flex.info flex.html
+ bash -n debian/flex-doc.postinst
+ bash -n debian/flex-doc.prerm
+ bash -n debian/flex.postinst
+ bash -n debian/flex.prerm
+
+override_dh_installman:
+ dh_installman
+ dh_link usr/share/man/man1/flex.1 usr/share/man/man1/flex++.1
+ dh_link usr/share/man/man1/flex.1 usr/share/man/man1/lex.1
+
+#Local variables:
+#mode: makefile
+#End: