summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-05-26 18:13:23 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-05-26 18:13:23 -0700
commitcf22f02ecc6f7b2cca999316732b63b7f91bc8f3 (patch)
tree3f14efb1a5519b47810532c0945c6cd99df847e2 /debian/rules
parentafcf3658e0b979a1bd7a3d54e9581f0c627a3d3f (diff)
[master]: Clean up rules and dependencies
* dh-autoreconf already depends on all the autotools that it will attempt to use to rebuild the package's build framework, so remove the direct (and redundant) dependencies on the autotools packages. Suggestion by Peter Pentchev (Closes: #749341). * The patch also cleaned up the creation of examples and links for man pages. Signed-off-by: Manoj Srivastava <srivasta@golden-gryphon.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 3 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index 514b19e..a27811c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -49,6 +49,9 @@ ifneq (,$(filter libfl-dev, $(shell dh_listpackages)))
debian/libfl.shared_object > debian/libfl-dev/usr/lib/$(DEB_HOST_MULTIARCH)/libfl.so
ln -s libfl.a debian/libfl-dev/usr/lib/$(DEB_HOST_MULTIARCH)/libl.a
endif
+ifneq (,$(filter flex, $(shell dh_listpackages)))
+ test ! -f debian/flex/usr/share/doc/flex/COPYING || rm -f debian/flex/usr/share/doc/flex/COPYING
+endif
dh_link
@@ -58,15 +61,6 @@ ifneq (,$(filter flex-doc, $(shell dh_listpackages)))
mv debian/flex-doc/usr/share/doc/flex-doc/flex.html debian/flex-doc/usr/share/doc/flex-doc/html
endif
-override_dh_installexamples:
- dh_installexamples
-ifneq (,$(filter flex, $(shell dh_listpackages)))
- mv debian/flex/usr/share/doc/flex/examples/examples debian/flex/usr/share/doc/flex/tmp
- rmdir debian/flex/usr/share/doc/flex/examples
- mv debian/flex/usr/share/doc/flex/tmp debian/flex/usr/share/doc/flex/examples
- test ! -f debian/flex/usr/share/doc/flex/COPYING || rm -f debian/flex/usr/share/doc/flex/COPYING
-endif
-
override_dh_auto_build:
dh_auto_build
$(MAKE) -C doc flex.info flex.html
@@ -75,11 +69,6 @@ override_dh_auto_build:
bash -n debian/flex.postinst
bash -n debian/flex.prerm
-override_dh_installman:
- dh_installman
- dh_link usr/share/man/man1/flex.1 usr/share/man/man1/flex++.1
- dh_link usr/share/man/man1/flex.1 usr/share/man/man1/lex.1
-
#Local variables:
#mode: makefile
#End: