summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-06-20 21:01:27 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-06-20 21:01:27 -0700
commitd7b859a063a26d2b72592ac238f7915d8ff797b3 (patch)
treeb7b09cd08efda56516067f62dc2d49091522d115 /debian/rules
parentcdb2ef615a96603622246d8fa7525bcb04f80a65 (diff)
[master]: Build dependency fixes, no code change
Added a missing build depends on vm-super-minimal, reuired fro building the pdf documentation, (Closes: #752151). Move flex.pdf to the flex-doc package. This makes it possible for the flex package's contents to not change if texinfo is not installed, e.g. in the stage1 build profile. Thanks to Peter Pentchev <roam@ringlet.net> Move the flex-doc build dependencies to B-D-I. Move the TeX Live dependencies to Build-Depends-Indep and only build the HTML and PDF documentation if actually requested. This breaks a circular build dependency by not requiring texlive for the build of the arch-dependent flex binary packages. (Closes: #749344). Signed-off-by: Manoj Srivastava <srivasta@golden-gryphon.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 545b173..029e492 100755
--- a/debian/rules
+++ b/debian/rules
@@ -37,6 +37,7 @@ override_dh_auto_configure:
fi; \
fi
dh_auto_configure -- --prefix=$(PREFIX) $(confflags)
+ sed -i -e 's/^dist_doc_DATA[[:space:]]*=.*/dist_doc_DATA=/' doc/Makefile
override_dh_install:
test ! -d debian/tmp/lib/$(DEB_HOST_MULTIARCH) || \
@@ -64,7 +65,9 @@ endif
override_dh_auto_build:
dh_auto_build
- $(MAKE) -C doc flex.info flex.html
+ifneq (,$(filter flex-doc, $(shell dh_listpackages)))
+ $(MAKE) -C doc flex.html flex.pdf
+endif
bash -n debian/flex-doc.postinst
bash -n debian/flex-doc.prerm
bash -n debian/flex.postinst