summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-04-17 02:18:11 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-04-17 02:39:54 -0700
commit86d91eea2ddacdbbcff932bce2b91aeaf70ab965 (patch)
treea583e3f75ae37a62a8d89eea984d5a962c48509b /debian/rules
parent7db3bf58a48b9952fac1fd907fb23f5d257ed7ec (diff)
New bug fixing release
Bug fix: "typo in README.Debian: libfla_pic.a -&gt; libfl_pic.a", thanks to Jakub Wilk (Closes: #744853). Bug fix: "libfl-dev and flex-old: error when trying to install together", thanks to Ralf Treinen. The package libfl-dev needs to replace and Break the flex-old package too, (Closes: #744833). Bug fix: "redundant redeclaration of ‘isatty’", thanks to Ludovic Rousseau. This duplication was removed in the last upstream release. (Closes: #488274). Bug fix: "flex-2.5.35 bug", thanks to Yuriy Z. scan.c now declares n as size_t, in the new upstream version. (Closes: #633008). Bug fix: "make check failure", thanks to Sayre, Alan N. The new version of flex does succeed in running make check (it would not build otherwise) (Closes: #632095).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 1e411ce..9ee7e16 100755
--- a/debian/rules
+++ b/debian/rules
@@ -40,7 +40,11 @@ override_dh_install:
sed -e 's,#DEB_HOST_MULTIARCH#,$(DEB_HOST_MULTIARCH),' \
debian/libfl.shared_object > debian/libfl-dev/usr/lib/$(DEB_HOST_MULTIARCH)/libfl.so
dh_link usr/lib/$(DEB_HOST_MULTIARCH)/libfl.a usr/lib/$(DEB_HOST_MULTIARCH)/libl.a
- dh_link usr/bin/flex usr/bin/lex
+ test ! -e debian/flex/usr/lib/$(DEB_HOST_MULTIARCH)/libf.a || \
+ mv debian/flex/usr/lib/$(DEB_HOST_MULTIARCH)/libf.a \
+ debian/libfl-dev/usr/lib/$(DEB_HOST_MULTIARCH)/
+ test ! -d debian/flex/usr/lib/$(DEB_HOST_MULTIARCH) || \
+ rmdir debian/flex/usr/lib/$(DEB_HOST_MULTIARCH) || true
override_dh_installdocs: