summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2020-05-20 22:12:43 -0700
committerManoj Srivastava <srivasta@debian.org>2020-05-20 22:12:43 -0700
commit9a63bbbb56fdb3420799b1c9e46e251decf52932 (patch)
treec4b6dfe67dd585be71a0e5ed9d64f7fb5034e7a9 /debian/rules
parent588705993b596b98dabb5a582fd54a22791043f9 (diff)
fix(paths): correct path specificans in the rulesdebian/2.6.4-7archive/debian/2.6.4-7
Do not embed build paths in example fiol;es, and pass paths to the configure script to standardize pathnames on ustmerge systems. Signed-off-by: Manoj Srivastava <srivasta@debian.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index f8ee94e..015f80a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,6 +32,8 @@ DEB_REVISION := $(strip $(shell echo $(DEB_NOEPOCH_VERSION)
DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
confflags = ac_cv_lib_util_getloadavg=no
+# Pass variables to ensure reproducible builds when built on usrmerge system
+confflags += GREP=/bin/grep MKDIR_P="/bin/mkdir -p" SED=/bin/sed SHELL=/bin/bash
ifneq ($(DEB_BUILD_MULTIARCH),$(DEB_HOST_MULTIARCH))
confflags += ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes
endif
@@ -90,6 +92,19 @@ ifneq (,$(filter flex-doc, $(shell dh_listpackages)))
debian/flex-doc/usr/share/doc/flex-doc/
endif
+override_dh_installexamples:
+ dh_installexamples
+ # Clean up embedded build paths in order to ensure reproducible builds.
+ sed -i -e "s,-fdebug-prefix-map=$(CURDIR)=\.,,g" \
+ -e "s,-ffile-prefix-map=$(CURDIR)=\.,,g" \
+ -e "s,abs_.*$(CURDIR).*,,g" \
+ -e "s,$(CURDIR).*missing --run,,g" \
+ -e "s,$(CURDIR),./,g" \
+ $(CURDIR)/debian/flex/usr/share/doc/flex/examples/fastwc/Makefile \
+ $(CURDIR)/debian/flex/usr/share/doc/flex/examples/manual/Makefile
+
+
+
override_dh_auto_build:
dh_auto_build
ifneq (,$(filter flex-doc, $(shell dh_listpackages)))