summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-05-06 23:58:39 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-05-06 23:58:39 -0700
commitafcf3658e0b979a1bd7a3d54e9581f0c627a3d3f (patch)
tree0d5436854926e5aab94d2ef7fcb2dc61b3566448 /debian
parent53702db419600deb77a88b5d5b791e1d4d44bb9f (diff)
[master]: Fix off by one error in line numbering
The code that is generated by flex has an off-by-one error in the generated #line pragmas that occur after the second %% line in the source file. Marcus Rausch supplied the patch that fixes it. (Closes: #542482). Signed-off-by: Manoj Srivastava <srivasta@golden-gryphon.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/patches/0001-debcherry-fixup-patch.patch8
-rw-r--r--debian/patches/0002-Finish-fixing-the-ia64-buffer-issue.patch6
-rw-r--r--debian/patches/0003-ia64-buffer-fix-Some-more-fixes-for-the-ia64-buffer-.patch6
-rw-r--r--debian/patches/0004-bison-test-fixes-Do-not-use-obsolete-bison-construct.patch6
-rw-r--r--debian/patches/0005-fix-off-by-one-error-generatred-line-numbers-are-off.patch53
-rw-r--r--debian/patches/series1
7 files changed, 78 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index cc40cf3..dc168ff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+flex (2.5.39-6) unstable; urgency=low
+
+ * The code that is generated by flex has an off-by-one error in the
+ generated #line pragmas that occur after the second %% line in the
+ source file. Marcus Rausch supplied the patch that fixes it.
+ (Closes: #542482).
+ * Bug fix #542482: "Off-by-one error in line statements", thanks to
+ Wouter Verhelst
+
+ -- Manoj Srivastava <srivasta@debian.org> Tue, 06 May 2014 23:57:31 -0700
+
flex (2.5.39-5) unstable; urgency=low
* Adapted patch from Matthias Klose to add pre-seeding of autoconf
diff --git a/debian/patches/0001-debcherry-fixup-patch.patch b/debian/patches/0001-debcherry-fixup-patch.patch
index 65a8872..f7c0c6a 100644
--- a/debian/patches/0001-debcherry-fixup-patch.patch
+++ b/debian/patches/0001-debcherry-fixup-patch.patch
@@ -1,7 +1,7 @@
-From 4c141a0575624fc7e22435a23ebf3d5c41ae6e42 Mon Sep 17 00:00:00 2001
+From 5976487aeeaf3321d938ed450d8767f434f6b1e9 Mon Sep 17 00:00:00 2001
From: Manoj Srivastava <srivasta@golden-gryphon.com>
-Date: Wed, 9 Apr 2014 00:42:31 -0700
-Subject: [PATCH 1/4] debcherry fixup patch
+Date: Tue, 6 May 2014 23:53:47 -0700
+Subject: [PATCH 1/5] debcherry fixup patch
61112fc [topic--autoconf0files] Delete files create by autoconf
- extra changes or conflicts
@@ -71,5 +71,5 @@ index d8e27f7..1937b34 100644
scanner.h: scanner.c
scanner.o: parser.h
--
-1.9.1
+2.0.0.rc0
diff --git a/debian/patches/0002-Finish-fixing-the-ia64-buffer-issue.patch b/debian/patches/0002-Finish-fixing-the-ia64-buffer-issue.patch
index 28f9405..472a158 100644
--- a/debian/patches/0002-Finish-fixing-the-ia64-buffer-issue.patch
+++ b/debian/patches/0002-Finish-fixing-the-ia64-buffer-issue.patch
@@ -1,7 +1,7 @@
-From d4ba98f3f5ba3173e6f77faab6c85e5ee3d72bdc Mon Sep 17 00:00:00 2001
+From 028b2841cadc8abddfa1a8907b5b7b3ed31dbd0c Mon Sep 17 00:00:00 2001
From: Cyril Brulebois <kibi@debian.org>
Date: Fri, 2 Jan 2009 06:53:39 +0100
-Subject: [PATCH 2/4] Finish fixing the ia64 buffer issue.
+Subject: [PATCH 2/5] Finish fixing the ia64 buffer issue.
Previous commits increased YY_READ_BUF_SIZE (where __ia64__ is defined) but
left YY_BUF_SIZE unchanged, so that didn't fix the problem in the end. In the
@@ -77,5 +77,5 @@ index 6dc7644..128cdb3 100644
"",
"m4_ifdef( [[M4_YY_NOT_IN_HEADER]],",
--
-1.9.1
+2.0.0.rc0
diff --git a/debian/patches/0003-ia64-buffer-fix-Some-more-fixes-for-the-ia64-buffer-.patch b/debian/patches/0003-ia64-buffer-fix-Some-more-fixes-for-the-ia64-buffer-.patch
index 2c6fdf9..754b69d 100644
--- a/debian/patches/0003-ia64-buffer-fix-Some-more-fixes-for-the-ia64-buffer-.patch
+++ b/debian/patches/0003-ia64-buffer-fix-Some-more-fixes-for-the-ia64-buffer-.patch
@@ -1,7 +1,7 @@
-From d5a900c9ea3ac0a1602422b9adfe29372d11e826 Mon Sep 17 00:00:00 2001
+From 2cd06e17a6500865438007bd7983c9823269cb99 Mon Sep 17 00:00:00 2001
From: Manoj Srivastava <srivasta@golden-gryphon.com>
Date: Fri, 2 Jan 2009 07:23:39 +0100
-Subject: [PATCH 3/4] [ia64-buffer-fix]]: Some more fixes for the ia64 buffer
+Subject: [PATCH 3/5] [ia64-buffer-fix]]: Some more fixes for the ia64 buffer
issue.
Signed-off-by: Manoj Srivastava <srivasta@golden-gryphon.com>
@@ -71,5 +71,5 @@ index 128cdb3..4ef6e3a 100644
"",
"m4_ifdef( [[M4_YY_NOT_IN_HEADER]],",
--
-1.9.1
+2.0.0.rc0
diff --git a/debian/patches/0004-bison-test-fixes-Do-not-use-obsolete-bison-construct.patch b/debian/patches/0004-bison-test-fixes-Do-not-use-obsolete-bison-construct.patch
index 466c75d..729571f 100644
--- a/debian/patches/0004-bison-test-fixes-Do-not-use-obsolete-bison-construct.patch
+++ b/debian/patches/0004-bison-test-fixes-Do-not-use-obsolete-bison-construct.patch
@@ -1,7 +1,7 @@
-From 20ab0512841996f895a43d4490f695206ad0e4a2 Mon Sep 17 00:00:00 2001
+From d3d8bc98898f2b917062d8ef935de9bb0a50b540 Mon Sep 17 00:00:00 2001
From: Manoj Srivastava <srivasta@golden-gryphon.com>
Date: Wed, 9 Apr 2014 00:23:07 -0700
-Subject: [PATCH 4/4] [bison-test-fixes] Do not use obsolete bison constructs
+Subject: [PATCH 4/5] [bison-test-fixes] Do not use obsolete bison constructs
in tests.
In Bison 3.0, support for YYLEX_PARAM and YYPARSE_PARAM has been
@@ -73,5 +73,5 @@ index 0ffdb89..626c5e7 100644
%union {
long unused;
--
-1.9.1
+2.0.0.rc0
diff --git a/debian/patches/0005-fix-off-by-one-error-generatred-line-numbers-are-off.patch b/debian/patches/0005-fix-off-by-one-error-generatred-line-numbers-are-off.patch
new file mode 100644
index 0000000..280d392
--- /dev/null
+++ b/debian/patches/0005-fix-off-by-one-error-generatred-line-numbers-are-off.patch
@@ -0,0 +1,53 @@
+From 0784556690a1f33ea44a03d20312ef439ae5cc32 Mon Sep 17 00:00:00 2001
+From: Manoj Srivastava <srivasta@golden-gryphon.com>
+Date: Tue, 6 May 2014 23:50:05 -0700
+Subject: [PATCH 5/5] [fix-off-by-one-error]: generatred line numbers are off
+ by one
+
+The code that is generated by flex has an off-by-one error in the
+generated #line pragmas that occur after the second %% line in the
+source file (that is, the one that is used after the token patterns). As
+a result, gdb will think we're, e.g., on line 46 when in reality we're
+on line 45.
+
+Marcus Rausch supplied the patch in this commit
+
+Signed-off-by: Manoj Srivastava <srivasta@golden-gryphon.com>
+---
+ gen.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/gen.c b/gen.c
+index 8261951..1594dcf 100644
+--- a/gen.c
++++ b/gen.c
+@@ -1084,7 +1084,7 @@ void gentabs ()
+ out_str_dec (long_align ? get_int32_decl () :
+ get_int16_decl (), "yy_acclist", MAX (numas,
+ 1) + 1);
+-
++
+ buf_prints (&yydmap_buf,
+ "\t{YYTD_ID_ACCLIST, (void**)&yy_acclist, sizeof(%s)},\n",
+ long_align ? "flex_int32_t" : "flex_int16_t");
+@@ -1092,7 +1092,7 @@ void gentabs ()
+ yyacclist_tbl = (struct yytbl_data*)calloc(1,sizeof(struct yytbl_data));
+ yytbl_data_init (yyacclist_tbl, YYTD_ID_ACCLIST);
+ yyacclist_tbl->td_lolen = MAX(numas,1) + 1;
+- yyacclist_tbl->td_data = yyacclist_data =
++ yyacclist_tbl->td_data = yyacclist_data =
+ (flex_int32_t *) calloc (yyacclist_tbl->td_lolen, sizeof (flex_int32_t));
+ yyacclist_curr = 1;
+
+@@ -2158,7 +2158,7 @@ void make_tables ()
+ skelout ();
+
+ /* Copy remainder of input to output. */
+-
++ linenum--;
+ line_directive_out (stdout, 1);
+
+ if (sectnum == 3) {
+--
+2.0.0.rc0
+
diff --git a/debian/patches/series b/debian/patches/series
index fa60392..ddba361 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,3 +3,4 @@
0002-Finish-fixing-the-ia64-buffer-issue.patch
0003-ia64-buffer-fix-Some-more-fixes-for-the-ia64-buffer-.patch
0004-bison-test-fixes-Do-not-use-obsolete-bison-construct.patch
+0005-fix-off-by-one-error-generatred-line-numbers-are-off.patch