summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2003-02-27 15:37:44 +0000
committerWill Estes <wlestes@users.sourceforge.net>2003-02-27 15:37:44 +0000
commitc863276feb9ebec651b8840ffcd278e5ce9ce8e9 (patch)
treebf6f0b7922a5dbc7ea0bfe9c224f6bedb38e3242 /doc/Makefile.am
parent833f8a5da0c86aea228c5bb701a192154904a1e9 (diff)
move flex.texi and flex.1 to new doc/ subdirectory
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..a15ec54
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,22 @@
+help2man = @HELP2MAN@
+
+info_TEXINFOS = flex.texi
+man_MANS = flex.1
+
+MAINTAINERCLEANFILES = \
+ flex.1 \
+ flex.hks \
+ flex.ops
+
+EXTRA_DIST = \
+ $(man_MANS)
+
+if MAINTAINER_MODE
+../flex:
+ cd .. && $(MAKE) flex
+
+$(man_MANS): $(top_srcdir)/main.c ../flex
+ for i in $(man_MANS) ; do \
+ $(help2man) --name='fast lexical analyzer generator' --section=`echo $$i|rev|cut -f 1 -d .|rev` ../flex > $$i ; \
+ done
+endif