summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorAlastair Hughes <hobbitalastair@gmail.com>2016-10-27 16:48:49 +1300
committerWill Estes <westes575@gmail.com>2016-10-27 17:55:46 -0400
commit92311a56b34363d150ed6badfad3450bcfe09a2f (patch)
treefbca6574502e3fcdacb222b88f702d3fdbb9de36 /doc
parent2bf2ad6d686f5e2a3b6329ecedc756ddfcf71453 (diff)
Only regenerate the man page when required.
Make the flex binary an order-only prerequisite, and add back the prerequisites from before 7cfb440. This prevents rebuilding the man page whenever the flex binary is rebuilt, which causes problems if help2man is not installed and will never work when cross compiling. Fixes #108.
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 882843c..7ad39c7 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,5 +1,7 @@
help2man = @HELP2MAN@
+FLEX = $(top_builddir)/src/flex$(EXEEXT)
+
info_TEXINFOS = flex.texi
dist_man_MANS = flex.1
DISTCLEANFILES = flex.1
@@ -23,8 +25,8 @@ CLEANFILES = \
flex.vr \
flex.vrs
-flex.1: ../src/flex$(EXEEXT)
+flex.1: $(top_srcdir)/configure.ac $(top_srcdir)/src/flex.skl $(top_srcdir)/src/options.c $(top_srcdir)/src/options.h | $(FLEX)
$(help2man) --name='$(PACKAGE_NAME)' --section=1 \
--source='The Flex Project' --manual='Programming' \
- --output=$@ $< \
+ --output=$@ $(FLEX) \
|| rm -f $@