summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2018-02-08 11:16:54 -0800
committerManoj Srivastava <srivasta@debian.org>2018-02-08 11:16:54 -0800
commit5372d368306be0259401d04dcca0172c33cf43b0 (patch)
tree5f5545eebcc6924eba866c76e6241df16764cdb4 /doc
parent487177cbb85bc4e88e468c71b27569054b8df090 (diff)
parentab49343b08c933e32de8de78132649f9560a3727 (diff)
Merge tag 'v2.6.4' into upstream
version 2.6.4 Signed-off-by: Manoj Srivastava <srivasta@debian.org>
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.am34
-rw-r--r--doc/flex.texi27
2 files changed, 19 insertions, 42 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e6e97c8..523aa97 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,30 +1,14 @@
-help2man = @HELP2MAN@
+FLEX = $(top_builddir)/src/flex$(EXEEXT)
info_TEXINFOS = flex.texi
dist_man_MANS = flex.1
+MAINTAINERCLEANFILES = flex.1
-CLEANFILES = \
- flex.aux \
- flex.cp \
- flex.cps \
- flex.fn \
- flex.fns \
- flex.hk \
- flex.hks \
- flex.ky \
- flex.log \
- flex.op \
- flex.ops \
- flex.pg \
- flex.toc \
- flex.tp \
- flex.tps \
- flex.vr \
- flex.vrs
+CLEANFILES = *.aux *.cp *.cps *.fn *.fns *.hk *.hks *.ky *.log \
+ *.op *.ops *.pg *.toc *.tp *.tps *.vr *.vrs
-$(dist_man_MANS): $(top_srcdir)/configure.ac $(top_srcdir)/src/flex.skl $(top_srcdir)/src/options.c $(top_srcdir)/src/options.h
- for i in $(dist_man_MANS) ; do \
- $(help2man) --name='$(PACKAGE_NAME)' \
- --section=`echo $$i | sed -e 's/.*\.\([^.]*\)$$/\1/'` \
- $(top_srcdir)/src/flex$(EXEEXT) > $$i || rm -f $$i ; \
- done
+flex.1: $(top_srcdir)/configure.ac $(top_srcdir)/src/flex.skl $(top_srcdir)/src/options.c $(top_srcdir)/src/options.h | $(FLEX)
+ $(HELP2MAN) --name='$(PACKAGE_NAME)' --section=1 \
+ --source='The Flex Project' --manual='Programming' \
+ --output=$@ $(FLEX) \
+ || rm -f $@
diff --git a/doc/flex.texi b/doc/flex.texi
index af639f1..bccab1e 100644
--- a/doc/flex.texi
+++ b/doc/flex.texi
@@ -408,7 +408,7 @@ A somewhat more complicated example:
"+"|"-"|"*"|"/" printf( "An operator: %s\n", yytext );
- "{"[\^{}}\n]*"}" /* eat up one-line comments */
+ "{"[^{}\n]*"}" /* eat up one-line comments */
[ \t\n]+ /* eat up whitespace */
@@ -1491,15 +1491,14 @@ the scanning routine using a K&R-style/non-prototyped function
declaration, you must terminate the definition with a semi-colon (;).
@code{flex} generates @samp{C99} function definitions by
-default. However flex does have the ability to generate obsolete, er,
-@samp{traditional}, function definitions. This is to support
+default. Flex used to have the ability to generate obsolete, er,
+@samp{traditional}, function definitions. This was to support
bootstrapping gcc on old systems. Unfortunately, traditional
definitions prevent us from using any standard data types smaller than
-int (such as short, char, or bool) as function arguments. For this
-reason, future versions of @code{flex} may generate standard C99 code
-only, leaving K&R-style functions to the historians. Currently, if you
-do @strong{not} want @samp{C99} definitions, then you must use
-@code{%option noansi-definitions}.
+int (such as short, char, or bool) as function arguments. Furthermore,
+traditional definitions support added extra complexity in the skeleton file.
+For this reason, current versions of @code{flex} generate standard C99 code
+only, leaving K&R-style functions to the historians.
@cindex stdin, default for yyin
@cindex yyin
@@ -2183,7 +2182,7 @@ manages its own input buffer stack manually (instead of letting flex do it).
}
<<EOF>> {
- if ( --include_stack_ptr 0 )
+ if ( --include_stack_ptr == 0 )
{
yyterminate();
}
@@ -2860,19 +2859,13 @@ calls @code{yylex()} again).
@opindex ---option-ansi-definitions
@opindex ansi-definitions
@item --ansi-definitions, @code{%option ansi-definitions}
-instruct flex to generate ANSI C99 definitions for functions.
-This option is enabled by default.
-If @code{%option noansi-definitions} is specified, then the obsolete style
-is generated.
+Deprecated, ignored
@anchor{option-ansi-prototypes}
@opindex ---option-ansi-prototypes
@opindex ansi-prototypes
@item --ansi-prototypes, @code{%option ansi-prototypes}
-instructs flex to generate ANSI C99 prototypes for functions.
-This option is enabled by default.
-If @code{noansi-prototypes} is specified, then
-prototypes will have empty parameter lists.
+Deprecated, ignored
@anchor{option-bison-bridge}
@opindex ---bison-bridge