summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2002-03-05 14:47:36 +0000
committerWill Estes <wlestes@users.sourceforge.net>2002-03-05 14:47:36 +0000
commitb9c026a2c004fc8ae735c4735adcdd04e25b0798 (patch)
tree4e31338592c5f67e783daca54f521b25342fdb66 /examples
parentde8ca40a46cdb20c5f46b1901c7977d800d268d3 (diff)
examples/manual directory now fits into automake
Diffstat (limited to 'examples')
-rw-r--r--examples/manual/.cvsignore2
-rw-r--r--examples/manual/Makefile.am55
-rw-r--r--examples/manual/Makefile.examples88
-rw-r--r--examples/manual/README17
4 files changed, 151 insertions, 11 deletions
diff --git a/examples/manual/.cvsignore b/examples/manual/.cvsignore
new file mode 100644
index 0000000..282522d
--- /dev/null
+++ b/examples/manual/.cvsignore
@@ -0,0 +1,2 @@
+Makefile
+Makefile.in
diff --git a/examples/manual/Makefile.am b/examples/manual/Makefile.am
new file mode 100644
index 0000000..9ab3004
--- /dev/null
+++ b/examples/manual/Makefile.am
@@ -0,0 +1,55 @@
+# This file is part of flex.
+
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+
+# Neither the name of the University nor the names of its contributors
+# may be used to endorse or promote products derived from this software
+# without specific prior written permission.
+
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+# PURPOSE.
+
+EXTRA_DIST = \
+ ChangeLog \
+ Makefile.examples \
+ README \
+ cat.lex \
+ dates.lex \
+ datetest.dat \
+ eof_rules.lex \
+ eof_test01.txt \
+ eof_test02.txt \
+ eof_test03.txt \
+ expr.lex \
+ expr.y \
+ front.lex \
+ front.y \
+ j2t.lex \
+ myname.lex \
+ myname.txt \
+ myname2.lex \
+ numbers.lex \
+ pas_include.lex \
+ pascal.lex \
+ reject.lex \
+ replace.lex \
+ string1.lex \
+ string2.lex \
+ strtest.dat \
+ unput.lex \
+ user_act.lex \
+ userinit.lex \
+ wc.lex \
+ yymore.lex \
+ yymore2.lex \
+ yymoretest.dat
diff --git a/examples/manual/Makefile.examples b/examples/manual/Makefile.examples
new file mode 100644
index 0000000..f4d8297
--- /dev/null
+++ b/examples/manual/Makefile.examples
@@ -0,0 +1,88 @@
+#############################################################
+#
+# Makefile : Makefile for Flex examples.
+# Author : G.T.Nicol
+# Last Updated : 1993/10/05
+#
+# If you use bison, you may have to supply an alloca
+#
+#############################################################
+
+CC = gcc -g
+LEX = flex -i -I
+YACC = bison -d -y
+ALLOCA =
+
+############################################################
+#
+# DO NOT CHANGE ANYTHING FROM HERE ON !!!!!!!!!
+#
+############################################################
+
+all: expr front myname eof wc replace user_act string1\
+ string2 yymore numbers dates cat
+
+expr: expr.y expr.lex
+ $(YACC) expr.y
+ $(LEX) expr.lex
+ $(CC) -o expr lex.yy.c y.tab.c $(ALLOCA) -ll -lm
+
+front: front.y front.lex
+ $(YACC) front.y
+ $(LEX) front.lex
+ $(CC) -o front lex.yy.c y.tab.c $(ALLOCA) -ll -lm
+
+numbers: numbers.lex
+ $(LEX) numbers.lex
+ $(CC) lex.yy.c -o numbers
+
+dates: dates.lex
+ $(LEX) dates.lex
+ $(CC) lex.yy.c -o dates -ll
+
+yymore: yymore.lex
+ $(LEX) yymore.lex
+ $(CC) lex.yy.c -o yymore -ll
+
+string1: string1.lex
+ $(LEX) string1.lex
+ $(CC) lex.yy.c -o string1 -ll
+
+string2: string2.lex
+ $(LEX) string2.lex
+ $(CC) lex.yy.c -o string2 -ll
+
+myname: myname.lex
+ $(LEX) myname.lex
+ $(CC) lex.yy.c -o myname -ll
+
+myname2: myname2.lex
+ $(LEX) myname2.lex
+ $(CC) lex.yy.c -o myname2 -ll
+
+eof: eof_rules.lex
+ $(LEX) eof_rules.lex
+ $(CC) lex.yy.c -o eof -ll
+
+wc: wc.lex
+ $(LEX) wc.lex
+ $(CC) lex.yy.c -o wc -ll
+
+cat: cat.lex
+ $(LEX) cat.lex
+ $(CC) lex.yy.c -o cat -ll
+
+replace: replace.lex
+ $(LEX) replace.lex
+ $(CC) lex.yy.c -o replace -ll
+
+user_act: expr.y expr.lex
+ $(LEX) user_act.lex
+ $(CC) -o user_act lex.yy.c -ll
+
+clean:
+ rm -f *.BAK *.o core *~* *.a
+ rm -f *.tab.h *.tab.c
+ rm -f myname expr lex.yy.c *.out eof wc yymore
+ rm -f replace front user_act string1 string2
+ rm -f dates numbers cat
diff --git a/examples/manual/README b/examples/manual/README
index 860f300..e11569a 100644
--- a/examples/manual/README
+++ b/examples/manual/README
@@ -1,17 +1,12 @@
-This directory contains the example programs from the manual, and a few
-other things as well. To make all the programs, simply type "make",
-and assuming you have flex and gcc, all will be well.
+This directory contains the example programs from the manual, and a
+few other things as well. To make all the programs, simply type "make
+-f Makefile.examples", and assuming you have flex and gcc, all will be
+well.
To build the programs individually, type
- make program_name
+ make -f Makefile.examples program_name
For example:
- make expr
-
-
-The subdirectory FILTER contains a collection of the silly filters
-that have appeared on the Internet over the years. The author of the
-flex manual has included them for fun, but does not guarantee they will
-work with flex, or even work at all.
+ make -f Makefile.examples expr