summaryrefslogtreecommitdiff
path: root/flexdef.h
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2002-07-09 18:11:50 +0000
committerJohn Millaway <john43@users.sourceforge.net>2002-07-09 18:11:50 +0000
commit3cfbabfe5dea37286ed9fc7e697493e832affbbc (patch)
tree06e0f1a122df88875f50598a5fb7d538b7f142cd /flexdef.h
parent4fff5ecd99ef799c3d01672a83b997ebc85e71fb (diff)
Replaced obsolete macros in configure.in.
Modified create-test to handle the above changes in configure.in. Added support for <stdbool.h>.
Diffstat (limited to 'flexdef.h')
-rw-r--r--flexdef.h7
1 files changed, 6 insertions, 1 deletions
diff --git a/flexdef.h b/flexdef.h
index 93f7e10..9fc642b 100644
--- a/flexdef.h
+++ b/flexdef.h
@@ -124,9 +124,14 @@
#define isascii(c) ((c) <= 0177)
#endif
-
+#ifdef HAVE_STDBOOL_H
+#include <stdbool.h>
+#else
+#define bool int
#define true 1
#define false 0
+#endif
+
#define unspecified -1