summaryrefslogtreecommitdiff
path: root/flexdef.h
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2002-10-10 15:34:31 +0000
committerWill Estes <wlestes@users.sourceforge.net>2002-10-10 15:34:31 +0000
commit67165cf7c1215202050970836c51613fcefa9478 (patch)
tree8f54b7ed78070e6721543a0addb9a3f5c3c9fde3 /flexdef.h
parentfbbc339e0e787369d5c34e1df9483d79a42bffbe (diff)
redo integral types again; add flexint.h; change dependencies caused by adding flexint.h; remove autoconf wrapper around cunistd; restore netinet/in.h includes; remove unneded feature checks in configure.in
Diffstat (limited to 'flexdef.h')
-rw-r--r--flexdef.h11
1 files changed, 5 insertions, 6 deletions
diff --git a/flexdef.h b/flexdef.h
index 3dab6c4..814a885 100644
--- a/flexdef.h
+++ b/flexdef.h
@@ -49,12 +49,7 @@
#ifdef HAVE_LIMITS_H
#include <limits.h>
#endif
-#ifdef HAVE_SYS_TYPES_H
-#include <sys/types.h>
-#endif
-#ifdef HAVE_INTTYPES_H
-#include <inttypes.h>
-#endif
+#include "flexint.h"
#ifdef HAVE_UNISTD_H
#include <unistd.h>
#endif
@@ -128,6 +123,10 @@
#define unspecified -1
+#ifdef HAVE_NETINET_IN_H
+#include <netinet/in.h>
+#endif
+
/* Special chk[] values marking the slots taking by end-of-buffer and action
* numbers.
*/