summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2016-11-19 02:37:04 +0800
committerWill Estes <westes575@gmail.com>2016-11-24 18:45:07 -0500
commit713f5a0cb4ba5e4bfebae125edf4111fd8dae803 (patch)
tree3f648b9c502e61a3f02b8482abc592d18eda5124 /lib
parent11c445cde95ec4ba146b180bf3a2501cc6e255da (diff)
build: Link $(LIBOBJS) from src/ dir, remove libcompat.la.
The libcompat.la library was small and less friendly to bootstrapping and cross compilation. Now, we will simply link individual object files as needed, which is simpler.
Diffstat (limited to 'lib')
-rw-r--r--lib/Makefile.am5
-rw-r--r--lib/lib.c9
2 files changed, 1 insertions, 13 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 011163e..9ce06a8 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,4 +1 @@
-noinst_LTLIBRARIES = libcompat.la
-libcompat_la_SOURCES = lib.c
-libcompat_la_LIBADD = $(LTLIBOBJS)
-
+# dummy
diff --git a/lib/lib.c b/lib/lib.c
deleted file mode 100644
index 4b4bf73..0000000
--- a/lib/lib.c
+++ /dev/null
@@ -1,9 +0,0 @@
-/* Since building an empty library could cause problems, we provide a
- * function to go into the library. We could make this non-trivial by
- * moving something that flex treats as a library function into this
- * directory. */
-
-extern void do_nothing(void);
-
-void do_nothing(void){ return;}
-