summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2018-02-08 11:16:54 -0800
committerManoj Srivastava <srivasta@debian.org>2018-02-08 11:16:54 -0800
commit5372d368306be0259401d04dcca0172c33cf43b0 (patch)
tree5f5545eebcc6924eba866c76e6241df16764cdb4 /lib
parent487177cbb85bc4e88e468c71b27569054b8df090 (diff)
parentab49343b08c933e32de8de78132649f9560a3727 (diff)
Merge tag 'v2.6.4' into upstream
version 2.6.4 Signed-off-by: Manoj Srivastava <srivasta@debian.org>
Diffstat (limited to 'lib')
-rw-r--r--lib/Makefile.am4
-rw-r--r--lib/lib.c9
-rw-r--r--lib/reallocarray.c49
3 files changed, 0 insertions, 62 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
deleted file mode 100644
index 011163e..0000000
--- a/lib/Makefile.am
+++ /dev/null
@@ -1,4 +0,0 @@
-noinst_LTLIBRARIES = libcompat.la
-libcompat_la_SOURCES = lib.c
-libcompat_la_LIBADD = $(LTLIBOBJS)
-
diff --git a/lib/lib.c b/lib/lib.c
deleted file mode 100644
index 4b4bf73..0000000
--- a/lib/lib.c
+++ /dev/null
@@ -1,9 +0,0 @@
-/* Since building an empty library could cause problems, we provide a
- * function to go into the library. We could make this non-trivial by
- * moving something that flex treats as a library function into this
- * directory. */
-
-extern void do_nothing(void);
-
-void do_nothing(void){ return;}
-
diff --git a/lib/reallocarray.c b/lib/reallocarray.c
deleted file mode 100644
index 0c1e250..0000000
--- a/lib/reallocarray.c
+++ /dev/null
@@ -1,49 +0,0 @@
-/* $OpenBSD: reallocarray.c,v 1.2 2014/12/08 03:45:00 bcook Exp $ */
-/*
- * Copyright (c) 2008 Otto Moerbeek <otto@drijf.net>
- *
- * Permission to use, copy, modify, and distribute this software for any
- * purpose with or without fee is hereby granted, provided that the above
- * copyright notice and this permission notice appear in all copies.
- *
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
- * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
- * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
- * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- */
-
-/* OPENBSD ORIGINAL: lib/libc/stdlib/reallocarray.c */
-
-#include <config.h>
-#ifndef HAVE_REALLOCARRAY
-#undef reallocarray
-
-#include <sys/types.h>
-#include <errno.h>
-#ifdef HAVE_STDINT_H
-#include <stdint.h>
-#endif
-#include <stdlib.h>
-
-void *reallocarray(void *, size_t, size_t);
-
-/*
- * This is sqrt(SIZE_MAX+1), as s1*s2 <= SIZE_MAX
- * if both s1 < MUL_NO_OVERFLOW and s2 < MUL_NO_OVERFLOW
- */
-#define MUL_NO_OVERFLOW ((size_t)1 << (sizeof(size_t) * 4))
-
-void *
-reallocarray(void *optr, size_t nmemb, size_t size)
-{
- if ((nmemb >= MUL_NO_OVERFLOW || size >= MUL_NO_OVERFLOW) &&
- nmemb > 0 && SIZE_MAX / nmemb < size) {
- errno = ENOMEM;
- return NULL;
- }
- return realloc(optr, size * nmemb);
-}
-#endif /* HAVE_REALLOCARRAY */