summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-07-31 15:00:12 -0700
committerManoj Srivastava <srivasta@debian.org>2016-07-31 15:00:12 -0700
commitdc20a68ba953b2a5da0311f3ce9f9217f9ad60b3 (patch)
treee45fdd69828a8668029d07f8601442cbb9258559 /lib
parente68e1da425634fda40095a7b3196d4175f782987 (diff)
parent487177cbb85bc4e88e468c71b27569054b8df090 (diff)
Merge branch 'upstream'
Signed-off-by: Manoj Srivastava <srivasta@debian.org> # Conflicts: # src/buf.c # src/flex.skl # src/skel.c
Diffstat (limited to 'lib')
-rw-r--r--lib/Makefile.in5
-rw-r--r--lib/lib.c4
-rw-r--r--lib/reallocarray.c49
3 files changed, 56 insertions, 2 deletions
diff --git a/lib/Makefile.in b/lib/Makefile.in
index 158a047..30a2fe8 100644
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -174,7 +174,8 @@ am__define_uniq_tagged_files = \
ETAGS = etags
CTAGS = ctags
am__DIST_COMMON = $(srcdir)/Makefile.in \
- $(top_srcdir)/build-aux/depcomp malloc.c realloc.c
+ $(top_srcdir)/build-aux/depcomp malloc.c realloc.c \
+ reallocarray.c
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
ACLOCAL = @ACLOCAL@
ALLOCA = @ALLOCA@
@@ -264,6 +265,7 @@ SET_MAKE = @SET_MAKE@
SHARED_VERSION_INFO = @SHARED_VERSION_INFO@
SHELL = @SHELL@
STRIP = @STRIP@
+TEXI2DVI = @TEXI2DVI@
USE_NLS = @USE_NLS@
VERSION = @VERSION@
XGETTEXT = @XGETTEXT@
@@ -383,6 +385,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/malloc.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/realloc.Plo@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/reallocarray.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lib.Plo@am__quote@
.c.o:
diff --git a/lib/lib.c b/lib/lib.c
index a8ff70f..4b4bf73 100644
--- a/lib/lib.c
+++ b/lib/lib.c
@@ -3,5 +3,7 @@
* moving something that flex treats as a library function into this
* directory. */
-void do_nothing(){ return;}
+extern void do_nothing(void);
+
+void do_nothing(void){ return;}
diff --git a/lib/reallocarray.c b/lib/reallocarray.c
new file mode 100644
index 0000000..0c1e250
--- /dev/null
+++ b/lib/reallocarray.c
@@ -0,0 +1,49 @@
+/* $OpenBSD: reallocarray.c,v 1.2 2014/12/08 03:45:00 bcook Exp $ */
+/*
+ * Copyright (c) 2008 Otto Moerbeek <otto@drijf.net>
+ *
+ * Permission to use, copy, modify, and distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
+
+/* OPENBSD ORIGINAL: lib/libc/stdlib/reallocarray.c */
+
+#include <config.h>
+#ifndef HAVE_REALLOCARRAY
+#undef reallocarray
+
+#include <sys/types.h>
+#include <errno.h>
+#ifdef HAVE_STDINT_H
+#include <stdint.h>
+#endif
+#include <stdlib.h>
+
+void *reallocarray(void *, size_t, size_t);
+
+/*
+ * This is sqrt(SIZE_MAX+1), as s1*s2 <= SIZE_MAX
+ * if both s1 < MUL_NO_OVERFLOW and s2 < MUL_NO_OVERFLOW
+ */
+#define MUL_NO_OVERFLOW ((size_t)1 << (sizeof(size_t) * 4))
+
+void *
+reallocarray(void *optr, size_t nmemb, size_t size)
+{
+ if ((nmemb >= MUL_NO_OVERFLOW || size >= MUL_NO_OVERFLOW) &&
+ nmemb > 0 && SIZE_MAX / nmemb < size) {
+ errno = ENOMEM;
+ return NULL;
+ }
+ return realloc(optr, size * nmemb);
+}
+#endif /* HAVE_REALLOCARRAY */