summaryrefslogtreecommitdiff
path: root/main.c
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2002-03-28 19:52:33 +0000
committerJohn Millaway <john43@users.sourceforge.net>2002-03-28 19:52:33 +0000
commit712c03b38fb35f9d7f16e0fdd27441c3efda0071 (patch)
tree08ff0511d9f7e87cd0b0062239cbcd4f2e44c963 /main.c
parentf9365ab47fde213a761f90a5a0cc6437a4f30968 (diff)
Output of `flex --version` now matches GNU coding standards.
Makefile.am now uses `help2man` to generate flex.1
Diffstat (limited to 'main.c')
-rw-r--r--main.c11
1 files changed, 7 insertions, 4 deletions
diff --git a/main.c b/main.c
index b679d4d..28c91b7 100644
--- a/main.c
+++ b/main.c
@@ -1115,7 +1115,7 @@ char **argv;
break;
case OPT_VERSION:
- printf( _( "%s version %s\n" ),
+ printf( _( "%s %s\n" ),
program_name, flex_version );
exit( 0 );
@@ -1673,10 +1673,12 @@ void usage()
outfilename = outfile_path;
}
- fprintf(f,_( "%s [OPTIONS...] [file...]\n"), program_name);
+ fprintf(f,_( "Usage: %s [OPTIONS] [FILE]...\n"), program_name);
fprintf(f,
_(
-"Table Compression: (default is -Cem)\n"
+"Generates programs that perform pattern-matching on text.\n"
+"\n"
+"Table Compression:\n"
" -Ca, --align trade off larger tables for better memory alignment\n"
" -Ce, --ecs construct equivalence classes\n"
" -Cf do not compress tables; use -f representation\n"
@@ -1685,7 +1687,8 @@ _(
" -Cr, --read use read() instead of stdio for scanner input\n"
" -f, --full generate fast, large scanner. Same as -Cfr\n"
" -F, --fast use alternate table representation. Same as -CFr\n"
-
+" -Cem default compression (same as --ecs --meta-ecs)\n"
+
"\n"
"Debugging:\n"
" -d, --debug enable debug mode in scanner\n"