summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2017-02-06 12:04:03 -0500
committerWill Estes <westes575@gmail.com>2017-02-06 12:04:03 -0500
commit44f10b366f1337344862cf0138b2fb1d0805e740 (patch)
tree8186492042c9d0c30030f9626a6329d0668ad398 /src/Makefile.am
parenta7adbf20a91566510f61aa1c3c5193d3ff898d53 (diff)
build: don't assume distdir/scan.c is writeable
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2db07ef..b5827ab 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -92,8 +92,9 @@ stage1scan.c: scan.c
endif
dist-hook: scan.l flex$(EXEEXT)
+ chmod u+w $(distdir)/scan.c && \
./flex$(EXEEXT) -o scan.c $< && \
- mv scan.c $(distdir)
+ cp scan.c $(distdir)
# make needs to be told to make parse.h so that parallelized runs will
# not fail.