summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2016-11-26 17:21:25 +0800
committerWill Estes <westes575@gmail.com>2016-12-29 17:19:53 -0500
commit935478c3fe03346f6d6323f00424df07b2f04c70 (patch)
tree1ae89f51adf8280b7edd7453440e65340854731b /src/Makefile.am
parenta33e6fd5b4f0b56255604db4a42edf46ce5d85c0 (diff)
build: allow building libfl even with --disable-libfl.
For various reasons, we may wish to build libfl explicitly even when configure has been run with the --disable-libfl option. This is possible, now, via 'make -C src libfl.la'.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fdd3c92..0d267db 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -10,11 +10,11 @@ noinst_PROGRAMS = stage1flex
if ENABLE_LIBFL
lib_LTLIBRARIES = libfl.la
+endif
libfl_la_SOURCES = \
libmain.c \
libyywrap.c
libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
-endif
stage1flex_SOURCES = \
scan.l \