summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDemi Obenour <demiobenour@gmail.com>2016-09-24 23:35:07 -0400
committerWill Estes <westes575@gmail.com>2016-09-25 18:53:29 -0400
commitfb91984b3b0605b39fa8c2bdc7036fc074649742 (patch)
treee47095eb7c5a5050f7abc3b5f19cd4654643a214 /src/Makefile.am
parente50d903620be9b81e8dd89d1ed1063c13836ff26 (diff)
Simplify some shell code
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 815f244..e124836 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -81,12 +81,11 @@ DISTCLEANFILES = stage1scan.c
MAINTAINERCLEANFILES = skel.c
skel.c: flex.skl mkskel.sh flexint.h tables_shared.h tables_shared.c
- sed 's/m4_/m4postproc_/g; s/m4preproc_/m4_/g' $< | \
+ sed 's/4_/a4_/g; s/m4preproc_/m4_/g' $< | \
$(m4) -P -I $(srcdir) \
-DFLEX_MAJOR_VERSION=` echo $(VERSION)|cut -f 1 -d .` \
-DFLEX_MINOR_VERSION=` echo $(VERSION)|cut -f 2 -d .` \
-DFLEX_SUBMINOR_VERSION=`echo $(VERSION)|cut -f 3 -d .` | \
- sed 's/m4postproc_/m4_/g' | \
$(SHELL) $(srcdir)/mkskel.sh > $@.tmp
mv $@.tmp $@