summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2016-10-26 11:14:13 -0400
committerWill Estes <westes575@gmail.com>2016-10-26 14:09:36 -0400
commit2bf2ad6d686f5e2a3b6329ecedc756ddfcf71453 (patch)
treec65952202d161c5deec12324c5771fecbe40b434 /src/Makefile.am
parent023cd4f75476ab303e9fd881e36d48cb7d4a4ebf (diff)
build: no longer build PIC version of libfl.
The PIC version of libfl was not being built correctly. From the lack of bug reports around this problem, we conclude that the PIC version of libfl is not used and so we drop it from the build build targets for flex.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 77ddf4b..ffc9d2e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,8 +8,7 @@ m4 = @M4@
bin_PROGRAMS = flex
noinst_PROGRAMS = stage1flex
lib_LTLIBRARIES = \
- libfl.la \
- libfl_pic.la
+ libfl.la
stage1flex_SOURCES = \
scan.l \
@@ -62,12 +61,6 @@ libfl_la_SOURCES = \
libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
-libfl_pic_la_SOURCES = \
- libmain.c \
- libyywrap.c
-
-libfl_pic_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
-
include_HEADERS = \
FlexLexer.h