summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDemi Obenour <demiobenour@gmail.com>2017-05-03 10:29:01 -0400
committerWill Estes <westes575@gmail.com>2017-05-03 13:24:09 -0400
commit2f21edac99b5efc432417233e6e53326d630e08f (patch)
treefe5ac80946642004a477f2949a1b5d2ba0d09311 /src/Makefile.am
parent259257623937630bb22cabf29f9897270aa62ce0 (diff)
build: Delete comments from skeleton file.
Since the comments in flex.skl are, by hypothesis, not needed in skel.c, we remove them. THis reduces the size of the resulting executable somewhat.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7ecbf52..e379692 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -92,12 +92,7 @@ CLEANFILES = stage1scan.c stage1flex$(EXEEXT)
MAINTAINERCLEANFILES = skel.c
skel.c: flex.skl mkskel.sh flexint.h tables_shared.h tables_shared.c
- sed 's/4_/a4_/g; s/m4preproc_/m4_/g' $(srcdir)/flex.skl | \
- $(m4) -P -I $(srcdir) \
- -DFLEX_MAJOR_VERSION=` echo $(VERSION)|cut -f 1 -d .` \
- -DFLEX_MINOR_VERSION=` echo $(VERSION)|cut -f 2 -d .` \
- -DFLEX_SUBMINOR_VERSION=`echo $(VERSION)|cut -f 3 -d .` | \
- $(SHELL) $(srcdir)/mkskel.sh > $@.tmp
+ $(SHELL) $(srcdir)/mkskel.sh $(srcdir) $(m4) $(VERSION) > $@.tmp
mv $@.tmp $@
if ENABLE_BOOTSTRAP