summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorrlar <rlar>2016-03-31 15:21:48 +0200
committerWill Estes <westes575@gmail.com>2016-03-31 10:47:00 -0400
commit39cff7e23997e0d917cca1284c811c9c8ce4f825 (patch)
tree915ee2deb41d5eb0dcbed451dc6e817b6b0279ba /src/Makefile.am
parent07a1d30ba3dcdcfc27b800c9c6c74d18f6aa8779 (diff)
fix stage1scan.c and stage1scan.l dependency
git clean -fdx && ./autogen.sh && \ mkdir -p ../build && cd ../build && ../flex/configure && make -j10 failed with: > ../src/stage1flex -o stage1scan.c stage1scan.l > stage1flex: can't open stage1scan.l Note: stage1scan.c is not necessairy in the "make dist" generated tar.gz file. stage1flex will be build from scan.c (which is distributed), and this will then generate stage1scan.c from scan.l
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f8354ed..82e8f4e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,9 +18,11 @@ stage1flex_SOURCES = \
stage1flex_CFLAGS = $(AM_CFLAGS)
flex_SOURCES = \
- stage1scan.l \
$(COMMON_SOURCES)
+nodist_flex_SOURCES = \
+ stage1scan.c
+
flex_CFLAGS = $(AM_CFLAGS) $(WARNINGFLAGS)
COMMON_SOURCES = \
@@ -88,11 +90,8 @@ $(srcdir)/skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
$(SHELL) $(srcdir)/mkskel.sh >skel.c.tmp
mv skel.c.tmp $(srcdir)/skel.c
-stage1scan.l: scan.l
- cp $(srcdir)/scan.l $(srcdir)/stage1scan.l
-
-stage1scan.c: stage1scan.l stage1flex$(EXEEXT)
- $(top_builddir)/src/stage1flex$(EXEEXT) -o $@ $<
+stage1scan.c: scan.l stage1flex$(EXEEXT)
+ ./stage1flex$(EXEEXT) -o $@ $<
# make needs to be told to make parse.h so that parallelized runs will
# not fail.