summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorrlar <rlar>2016-03-31 11:19:20 -0400
committerWill Estes <westes575@gmail.com>2016-03-31 11:19:20 -0400
commit4db9c203f63f325994c8e199ed0b7beed043f448 (patch)
treeb5a98ee1e02dcd58f7cd0eb95279220af80c9ca3 /src/Makefile.am
parent7cfb440c7cbf438647a177ef45eef3201094079d (diff)
fix skel.c dependency (missing tables_shared.c) and
polish build rule Also remove references to srcdir since skel.c is no longer mentioned in po/POTFILES.in.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 82e8f4e..815f244 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -80,15 +80,15 @@ DISTCLEANFILES = stage1scan.c
MAINTAINERCLEANFILES = skel.c
-$(srcdir)/skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
- sed 's/m4_/m4postproc_/g; s/m4preproc_/m4_/g' $(srcdir)/flex.skl | \
+skel.c: flex.skl mkskel.sh flexint.h tables_shared.h tables_shared.c
+ sed 's/m4_/m4postproc_/g; s/m4preproc_/m4_/g' $< | \
$(m4) -P -I $(srcdir) \
-DFLEX_MAJOR_VERSION=` echo $(VERSION)|cut -f 1 -d .` \
-DFLEX_MINOR_VERSION=` echo $(VERSION)|cut -f 2 -d .` \
-DFLEX_SUBMINOR_VERSION=`echo $(VERSION)|cut -f 3 -d .` | \
sed 's/m4postproc_/m4_/g' | \
- $(SHELL) $(srcdir)/mkskel.sh >skel.c.tmp
- mv skel.c.tmp $(srcdir)/skel.c
+ $(SHELL) $(srcdir)/mkskel.sh > $@.tmp
+ mv $@.tmp $@
stage1scan.c: scan.l stage1flex$(EXEEXT)
./stage1flex$(EXEEXT) -o $@ $<