summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2017-01-02 20:10:58 +0800
committerWill Estes <westes575@gmail.com>2017-02-06 11:48:05 -0500
commita7adbf20a91566510f61aa1c3c5193d3ff898d53 (patch)
tree41d7e268dfae17ce583bf2e6a3f94688247a13e4 /src/Makefile.am
parentdae5c22f8727c57d4118b2bb57801014e3ade997 (diff)
build: Add dist-hook to force remake scan.c.
This will ensure the flex scanner included in release tarball being generated by exactly the flex version to be released. Here's one catch after this change: You may not run "make dist" or "make distdir" if you configure the flex source to be cross-compiled.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 12b2327..2db07ef 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -91,6 +91,10 @@ stage1scan.c: scan.c
sed 's|^\(#line .*\)"'`printf %s $< | sed 's|[][\\\\.*]|\\\\&|g'`'"|\1"$@"|g' $< > $@
endif
+dist-hook: scan.l flex$(EXEEXT)
+ ./flex$(EXEEXT) -o scan.c $< && \
+ mv scan.c $(distdir)
+
# make needs to be told to make parse.h so that parallelized runs will
# not fail.