summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMightyjo <mightyjo@gmail.com>2015-11-07 23:11:35 -0800
committerWill Estes <westes575@gmail.com>2015-11-08 14:59:29 -0500
commitcf6cb4dce791c26567cc506770ca96b4f4118024 (patch)
treeb7eba9b3bcfc6ea6a0ded96590434db6c16b17b4 /src/Makefile.am
parent5acd407ed42462c34783d7a31b3f7b1c34125c61 (diff)
Cleaned more generated sources.
Added skel.c explicitly to MAINTAINERCLEANFILES in src/Makefile.am. Added a bunch of files to built_SOURCES in tests/Makefile.am so that the suite is easier to clean up.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5353ebb..a1fc869 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -67,6 +67,8 @@ EXTRA_DIST = \
BUILT_SOURCES = \
skel.c
+MAINTAINERCLEANFILES = skel.c
+
skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
sed 's/m4_/m4postproc_/g; s/m4preproc_/m4_/g' $(srcdir)/flex.skl | $(m4) -P -DFLEX_MAJOR_VERSION=`echo $(VERSION)|cut -f 1 -d .` -DFLEX_MINOR_VERSION=`echo $(VERSION)|cut -f 2 -d .` -DFLEX_SUBMINOR_VERSION=`echo $(VERSION)|cut -f 3 -d .` | sed 's/m4postproc_/m4_/g' | $(SHELL) $(srcdir)/mkskel.sh >skel.c