summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorThomas Klausner <wiz@NetBSD.org>2017-01-23 08:46:48 +0100
committerWill Estes <westes575@gmail.com>2017-01-23 13:48:15 -0500
commit0a89eef5dc2df71258b036077178780ee983e009 (patch)
tree45ba0a1926484dabb11f2d8118f25777e50ecc0c /src
parentb61b0fe9062cde716a7a789a4bb34fdff9292ed1 (diff)
build: more BSD make and vpath build fixes.
BSD make doesn't like $< with more than one source specified. Additionally, make sure to specify srcdir when referring to source files since vpath builds depend on this.
Diffstat (limited to 'src')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9fe0788..f3fd83d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -76,7 +76,7 @@ CLEANFILES = stage1scan.c stage1flex$(EXEEXT)
MAINTAINERCLEANFILES = skel.c
skel.c: flex.skl mkskel.sh flexint.h tables_shared.h tables_shared.c
- sed 's/4_/a4_/g; s/m4preproc_/m4_/g' flex.skl | \
+ sed 's/4_/a4_/g; s/m4preproc_/m4_/g' $(srcdir)/flex.skl | \
$(m4) -P -I $(srcdir) \
-DFLEX_MAJOR_VERSION=` echo $(VERSION)|cut -f 1 -d .` \
-DFLEX_MINOR_VERSION=` echo $(VERSION)|cut -f 2 -d .` \
@@ -86,7 +86,7 @@ skel.c: flex.skl mkskel.sh flexint.h tables_shared.h tables_shared.c
if ENABLE_BOOTSTRAP
stage1scan.c: scan.l stage1flex$(EXEEXT)
- ./stage1flex$(EXEEXT) $(AM_LFLAGS) $(LFLAGS) -o $@ $<
+ ./stage1flex$(EXEEXT) $(AM_LFLAGS) $(LFLAGS) -o $@ $(srcdir)/scan.l
else
stage1scan.c: scan.c
sed 's|^\(#line .*\)"'`printf %s $< | sed 's|[][\\\\.*]|\\\\&|g'`'"|\1"$@"|g' $< > $@