summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2017-02-16 09:27:22 -0500
committerWill Estes <westes575@gmail.com>2017-02-16 09:27:22 -0500
commit2e820b6015a56552d7f7adb335b5830883d2973c (patch)
treeeb61306175166eac3d88d3aa1f5d82c7ca3023c0 /src
parent44f10b366f1337344862cf0138b2fb1d0805e740 (diff)
build: mv scan.c when building dist.
Revert change to copy scan.c when building the distribution archive. Move it instead. This satisfies automake's notions of what should be clean and ensures that the distribution archive contains a just-built copy of scan.c. Fixes #186
Diffstat (limited to 'src')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b5827ab..c24fcca 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -94,7 +94,7 @@ endif
dist-hook: scan.l flex$(EXEEXT)
chmod u+w $(distdir)/scan.c && \
./flex$(EXEEXT) -o scan.c $< && \
- cp scan.c $(distdir)
+ mv scan.c $(distdir)
# make needs to be told to make parse.h so that parallelized runs will
# not fail.