summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2017-01-01 15:41:29 +0800
committerWill Estes <westes575@gmail.com>2017-01-24 12:07:06 -0500
commita2fccbe579622bd3f4eb301040978f1f47bb70f1 (patch)
tree270c4d2cd171d85152a56d7152b82e7afaee172e /src
parente8cb34ed48f2b0e52b65e78360f9012db664be2f (diff)
build: fix Makefile parse.h dependency clauses.
The current clauses stating "main.c: parse.h" and "yylex.c: parse.h" do not work as expected. Make did not try to build parse.h upon building flex-main.o as it would think main.c exist already and ignore the clause. Fix this by explicitly stating that the .o files depend on parse.h instead. This dependency bug only happens if user builds flex from a checked-out repository.
Diffstat (limited to 'src')
-rw-r--r--src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f3fd83d..e504861 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -95,8 +95,12 @@ endif
# make needs to be told to make parse.h so that parallelized runs will
# not fail.
-main.c: parse.h
-yylex.c: parse.h
+stage1flex-main.$(OBJEXT): parse.h
+flex-main.$(OBJEXT): parse.h
+
+stage1flex-yylex.$(OBJEXT): parse.h
+flex-yylex.$(OBJEXT): parse.h
+
stage1flex-scan.$(OBJEXT): parse.h
flex-stage1scan.$(OBJEXT): parse.h