summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-14 11:46:44 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:27 -0500
commita0243585d226e5ce5d72bd21c31833517e55c26a (patch)
tree2d83602689b79f7e164d7ad81debf248016a1830 /tests/Makefile.am
parent5c48969b76b2141997af228b8cbbbb73bc3e4e57 (diff)
refactor top test for new test suite layout
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a749761..9863ecd 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -49,7 +49,8 @@ check_PROGRAMS = \
prefix_nr \
prefix_r \
string_nr \
-string_r
+string_r \
+ top
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -74,6 +75,7 @@ prefix_nr_SOURCES = prefix_nr.l
prefix_r_SOURCES = prefix_r.l
string_nr_SOURCES = string_nr.l
string_r_SOURCES = string_r.l
+top_SOURCES = top.l top_main.c
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -83,7 +85,8 @@ BUILT_SOURCES = \
bison_yylval_parser.h \
bison_yylval_scanner.h \
header_nr_scanner.h \
- header_r_scanner.h
+ header_r_scanner.h \
+ top.h
EXTRA_DIST = \
README \
@@ -112,7 +115,8 @@ basic_nr.txt \
noansi_nr.txt \
noansi_r.txt \
prefix_nr.txt \
- prefix_r.txt
+ prefix_r.txt \
+ top.txt
# specify how to process .l files in order to test the flex built by make all
@@ -135,3 +139,6 @@ header_nr_scanner.h: header_nr_scanner.c
header_r_main$(objext): header_r_scanner.h
header_r_scanner.h: header_r_scanner.c
+
+top_main$(objext): top.h
+top.h: top.c