summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-17 16:19:47 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:28 -0500
commitaaf002227e8bfb3009092717df6776b3fb1875ca (patch)
tree2cf17ce7270b6b20f3f30c169616fc075bab9793 /tests/Makefile.am
parente98b2df022fd47b62af35aebd3053f6e218f9926 (diff)
refactor concatenated options test for new test suite layout
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6ae705d..6ebafef 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,7 +19,7 @@
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
# PURPOSE.
-TESTS = $(check_PROGRAMS)
+TESTS = $(check_PROGRAMS) options.cn
# The script testwrapper.sh will run most tests as is. A couple tests
# in the suite end in .reject, .table and the like so that we can pass
@@ -27,7 +27,7 @@ TESTS = $(check_PROGRAMS)
# automake knows how to distinguish between the various kinds of tests
# we have.
-TEST_EXTENSIONS = .reject .table .direct
+TEST_EXTENSIONS = .reject .table .direct .cn
LOG_COMPILER = $(srcdir)/testwrapper.sh
AM_LOG_FLAGS = -d $(srcdir) -r
@@ -41,6 +41,9 @@ AM_TABLE_LOG_FLAGS = -d $(srcdir) -i reject.txt -t
DIRECT_LOG_COMPILER=$(srcdir)/testwrapper.sh
AM_DIRECT_LOG_FLAGS = -d $(srcdir)
+CN_LOG_COMPILER=$(srcdir)/options.cn
+AM_CN_LOG_FLAGS=$(FLEX)
+
AM_YFLAGS = -d -p test
check_PROGRAMS = $(simple_tests) $(reject_tests) $(TABLE_TESTS) $(DIRECT_TESTS)
@@ -214,7 +217,8 @@ basic_nr.txt \
quotes.txt \
top.h \
top.txt \
- yyextra.txt
+ yyextra.txt \
+ options.cn
# specify how to process .l files in order to test the flex built by make all