summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2017-02-07 21:14:04 +0800
committerWill Estes <westes575@gmail.com>2017-02-16 09:33:35 -0500
commit122e58965acaf67386d1fc6893f069bd27e5aa26 (patch)
treedebd9abd3046c080f407cb374694790b54d54780 /tests/Makefile.am
parent2e820b6015a56552d7f7adb335b5830883d2973c (diff)
test: skip pthread test when needed files missing.
"Unlisting" the pthread test when libpthread is not available is never a good idea. Should let it compile into a stub program that returns the "skip" status. configure.ac and tests/Makefile.am are edited so that pthread test can be built anyway, but only works (not as the stub) when both pthread.h and libpthread are detected on the system. Also fix a small typo in tests/pthread.l comments.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6b37705..845b767 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -113,10 +113,8 @@ DIRECT_TESTS = \
I3_TESTS = \
cxx_yywrap.i3
-if want_pthread
PTHREAD_TESTS = \
pthread.pthread
-endif
ONE_TESTS = \
lineno_nr.one \
@@ -331,7 +329,7 @@ dist_check_SCRIPTS = \
testwrapper-direct.sh \
testwrapper.sh
-pthread_pthread_LDADD = -lpthread
+pthread_pthread_LDADD = @LIBPTHREAD@
# specify how to process .l files in order to test the flex built by make all