summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-14 14:41:32 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:27 -0500
commit2d9cde08c72ac7b2cef908c3d006984a79bd997c (patch)
tree1af178ff238f449d92891132b1fdc24354ae01ce /tests/Makefile.am
parent435b336b2fbf2f4412fd4a5042afb095a3cf40e4 (diff)
refactor posixly_correct test for new test suite layout
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6e706b3..c2e943b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -46,6 +46,7 @@ check_PROGRAMS = \
noansi_nr \
noansi_r \
posix \
+ posixly_correct \
prefix_nr \
prefix_r \
string_nr \
@@ -72,6 +73,7 @@ mem_r_SOURCES = mem_r.l
noansi_nr_SOURCES = noansi_nr.l
noansi_r_SOURCES = noansi_r.l
posix_SOURCES = posix.l
+posixly_correct_SOURCES = posixly_correct.l
prefix_nr_SOURCES = prefix_nr.l
prefix_r_SOURCES = prefix_r.l
string_nr_SOURCES = string_nr.l
@@ -144,5 +146,8 @@ header_nr_scanner.h: header_nr_scanner.c
header_r_main$(objext): header_r_scanner.h
header_r_scanner.h: header_r_scanner.c
+posixly_correct.c: posixly_correct.l
+ POSIXLY_CORRECT=1 $(FLEX) -o $@ $<
+
top_main$(objext): top.h
top.h: top.c