summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2002-10-11 14:23:14 +0000
committerWill Estes <wlestes@users.sourceforge.net>2002-10-11 14:23:14 +0000
commit7a2f6d977ecca7887d17d600ef552e565e6e2282 (patch)
tree9a1153743a10338c3cad552b5ff6b8a48ef987eb /tests/Makefile.am
parentc38e0265d8031b078f936976974287626b6d501c (diff)
rename test to check-local as per Akim Demaille; test for failed tests
so that make check fails if any tests do
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b0fd415..2fd9449 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -98,7 +98,7 @@ SUBDIRS = \
# clean up before running the test suite so we dont test old builds of test code
-test: clean
+check-local: clean
NOK=;\
NFAIL=;\
for dir in $(SUBDIRS) ; do \
@@ -115,4 +115,5 @@ test: clean
done ; \
echo Results: ; \
echo Tests succeeded: `echo @ECHO_N@ "$$NOK@ECHO_C@"|wc -c`; \
- echo Tests FAILED: `echo @ECHO_N@ "$$NFAIL@ECHO_C@"|wc -c` ;
+ echo Tests FAILED: `echo @ECHO_N@ "$$NFAIL@ECHO_C@"|wc -c` ; \
+ test "$$NFAIL" = ""