summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-04 16:58:33 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:26 -0500
commit1c39506c5a670f120c7fae3181f2f5b0aa17653d (patch)
tree9c9db75990ba6e29145f0d351a2c890c67048514 /tests/Makefile.am
parentd342834a6b29b16fe15db9b339a89b8506fbb2d7 (diff)
refactor header_nr test for new test suite layout
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e41b5f2..1a47e14 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -38,7 +38,8 @@ check_PROGRAMS = \
ccl \
debug_nr \
debug_r \
- extended
+ extended \
+ header_nr
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -52,6 +53,7 @@ ccl_SOURCES = ccl.l
debug_nr_SOURCES = debug_nr.l
debug_r_SOURCES = debug_r.l
extended_SOURCES = extended.l
+header_nr_SOURCES = header_nr_scanner.l header_nr_main.c
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -59,7 +61,8 @@ BUILT_SOURCES = \
bison_yylloc_parser.h \
bison_yylloc_scanner.h \
bison_yylval_parser.h \
- bison_yylval_scanner.h
+ bison_yylval_scanner.h \
+ header_nr_scanner.h
EXTRA_DIST = \
README \
@@ -78,7 +81,9 @@ basic_nr.txt \
ccl.txt \
debug_nr.txt \
debug_r.txt \
- extended.txt
+ extended.txt \
+ header_nr_scanner.h \
+ header_nr.txt
# specify how to process .l files in order to test the flex built by make all
@@ -95,3 +100,6 @@ bison_yylloc_scanner.h: bison_yylloc_scanner.c
bison_yylval_main$(objext): bison_yylval_parser.h bison_yylval_scanner.h
bison_yylval_scanner.h: bison_yylval_scanner.c
+
+header_nr_main$(objext): header_nr_scanner.h
+header_nr_scanner.h: header_nr_scanner.c