summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-14 11:48:48 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:27 -0500
commit435b336b2fbf2f4412fd4a5042afb095a3cf40e4 (patch)
treec7dc96ef12a594640fd603d7d4d5e2febcaa3983 /tests/Makefile.am
parenta0243585d226e5ce5d72bd21c31833517e55c26a (diff)
refactor yyextra test for new test suite layout
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9863ecd..6e706b3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -50,7 +50,8 @@ check_PROGRAMS = \
prefix_r \
string_nr \
string_r \
- top
+ top \
+ yyextra
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -76,6 +77,7 @@ prefix_r_SOURCES = prefix_r.l
string_nr_SOURCES = string_nr.l
string_r_SOURCES = string_r.l
top_SOURCES = top.l top_main.c
+yyextra_SOURCES = yyextra.l
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -116,7 +118,9 @@ basic_nr.txt \
noansi_r.txt \
prefix_nr.txt \
prefix_r.txt \
- top.txt
+ top.h \
+ top.txt \
+ yyextra.txt
# specify how to process .l files in order to test the flex built by make all