summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-04 09:04:09 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:26 -0500
commit82f6a7cc2c75b09a7fb505ecbeaf6fc5f80622f9 (patch)
tree7a6138555c0da5c57cd499fd5777b4ad99941027 /tests/Makefile.am
parentbb00ab6892df1799c25790cf2f48c9260f4ff059 (diff)
refactor bison-yylloc test for new test suite layout
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1d23e40..b180c88 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -32,7 +32,8 @@ check_PROGRAMS = \
array-r \
basic-nr \
basic-r \
- bison-nr
+ bison-nr \
+ bison-yylloc
alloc_extra_SOURCES = alloc-extra.l
array_nr_SOURCES = array-nr.l
@@ -40,10 +41,13 @@ array_r_SOURCES = array-r.l
basic_nr_SOURCES = basic-nr.l
basic_r_SOURCES = basic-r.l
bison_nr_SOURCES = bison-nr-scanner.l bison-nr-parser.y bison-nr-main.c
+bison_yylloc_SOURCES = bison-yylloc-scanner.l bison-yylloc-parser.y bison-yylloc-main.c
BUILT_SOURCES = \
bison-nr-scanner.h \
- bison-nr-parser.h
+ bison-nr-parser.h \
+ bison-yylloc-parser.h \
+ bison-yylloc-scanner.h
EXTRA_DIST = \
README \
@@ -54,7 +58,9 @@ EXTRA_DIST = \
basic-nr.txt \
basic-r.txt \
bison-nr-scanner.h \
- bison-nr.txt
+ bison-nr.txt \
+ bison-yylloc-scanner.h \
+ bison-yylloc.txt
# specify how to process .l files in order to test the flex built by make all
@@ -65,3 +71,6 @@ FLEX = $(top_builddir)/src/flex
bison-nr-main($objext): bison-nr-parser.h bison-nr-scanner.h
bison-nr-scanner.h: bison-nr-scanner.c
+
+bison-yylloc-main$(objext): bison-yylloc-parser.h bison-yylloc-scanner.h
+bison-yylloc-scanner.h: bison-yylloc-scanner.c