summaryrefslogtreecommitdiff
path: root/tests/README
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2001-06-17 19:12:39 +0000
committerWill Estes <wlestes@users.sourceforge.net>2001-06-17 19:12:39 +0000
commit9a3ba1a3cdf55c0b8d4751d706d1d0424d8f4d7c (patch)
tree91a1eac65da59100afcae71733f8131bdecb3913 /tests/README
parent70985a5c73359ac35c04033e91bd79cc9d3e4cf5 (diff)
reformat, say to add a description to this file and mention what to do re .cvsignore
Diffstat (limited to 'tests/README')
-rw-r--r--tests/README32
1 files changed, 16 insertions, 16 deletions
diff --git a/tests/README b/tests/README
index 8ca3ede..2936cc2 100644
--- a/tests/README
+++ b/tests/README
@@ -1,13 +1,11 @@
This file describes the flex tests.
-
WHO SHOULD USE THE TESTS
The test suite is intended to be used by flex developers, i.e., anyone hacking
the flex distribution. If you are simply installing flex, then you can ignore
this directory and its contents.
-
STRUCTURE OF THE TESTS
The test suite consists of several flex scanners, one per directory, known
@@ -17,38 +15,42 @@ may require certain tools to be available (e.g., bison, diff). If any test
returns an error or generates an error message, then your modifications *may*
have broken a feature of flex.
-
HOW TO RUN THE TESTS
To build and execute all tests:
- $ cd TESTS/
- $ make
+ $ cd tests/ # from the top level of the flex source tree
$ make check
-
To build and execute a single test:
- $ cd TESTS/
- $ cd test-pthread-nr
+ $ cd tests/ #from the top level of the flex tree
+ $ cd test-pthread-nr # for example
$ make
$ make check
-
HOW TO ADD A NEW TEST
- - Copy the TESTS/TEMPLATE directory, then
- modify the skeleton scanner (and parser if necessary).
+ - Copy the tests/TEMPLATE directory, then modify the skeleton scanner
+ (and parser if necessary). If you are submitting a patch for
+ inclusion in the flex distribution, then move the file "cvsignore"
+ to .cvsignore in your new test-* subdirectory and add the name of
+ your directory on a line by itself at the end of the newly created
+ .cvsignore file. This will make it easier on the flex maintainer to
+ include your new test in the cvs tree.
- On success, your test should return zero.
On error, your test should return non-zero and print a message
- to stderr.
+ to stderr. Hopefullly, your error message will indicate something
+ helpful to explain why the test failed.
- - You must modify the last few lines of TESTS/Makefile.in
+ - You must modify the last few lines of tests/Makefile.in
by adding your new test directory, and the Makefile target.
- Each test assumes that the newly-built binary "flex" is in the
- directory above the TESTS directory.
+ directory above the tests directory.
+
+ - Add a description of your new test to the end of this file.
DESCRIPTION OF TESTS
@@ -65,5 +67,3 @@ DESCRIPTION OF TESTS
string-nr - Scan strings, non-reentrant.
string-r - Scan strings, reentrant.
yyextra - User-specific data in reentrant scanner.
-
-