summaryrefslogtreecommitdiff
path: root/tests/README
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2002-02-21 05:12:10 +0000
committerJohn Millaway <john43@users.sourceforge.net>2002-02-21 05:12:10 +0000
commitea3edb34c48829d66a225f23077d6d0e29eb2746 (patch)
treef8c9a794755ee612045025e9ddb9af5c49034ca0 /tests/README
parentde30476ad1683c9b00ede70a8076effb0e44dec5 (diff)
Added test-c-cpp-nr and test-c-cpp-r.
Diffstat (limited to 'tests/README')
-rw-r--r--tests/README7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/README b/tests/README
index 031cc99..24d0534 100644
--- a/tests/README
+++ b/tests/README
@@ -30,6 +30,9 @@ To build and execute a single test:
HOW TO ADD A NEW TEST
+ - Run the perl script `create-test.pl` found in this directory.
+ If it works, skip the next step.
+
- Copy the tests/TEMPLATE directory, then modify the skeleton scanner
(and parser if necessary). If you are submitting a patch for
inclusion in the flex distribution, then move the file "cvsignore"
@@ -49,6 +52,7 @@ HOW TO ADD A NEW TEST
- You must modify the last few lines of tests/configure.in
by adding your new test directory, and the Makefile target.
+ (This step is done automatically by `create-test.pl`.)
- Each test assumes that the newly-built binary "flex" is in the
directory above the tests directory.
@@ -73,4 +77,5 @@ DESCRIPTION OF TESTS
pthread - pthreads test. A NO-OP if libpthread not found.
string-nr - Scan strings, non-reentrant.
string-r - Scan strings, reentrant.
- yyextra - User-specific data in reentrant scanner.
+ c-cpp-nr - Compile a C scanner with C++ compiler, nonreentrant.
+ c-cpp-r - Compile a C scanner with C++ compiler, reentrant.