summaryrefslogtreecommitdiff
path: root/tests/bison_nr_parser.y
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-22 13:36:58 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-22 13:36:58 -0800
commit426e91fa66c2a2341d46f977ee351bd24ef3331c (patch)
treeb4d506125335b5e5d748ac284b7239e10df96d21 /tests/bison_nr_parser.y
parent26bb2525c89ecda0b0bc7b597ec8d1b792fc8662 (diff)
parent83d5d1695a2ab1d69ea4d8e7df27146c644876fc (diff)
Merge tag 'v2.6.0' into upstream
flex v2.6.0 release Signed-off-by: Manoj Srivastava <srivasta@debian.org> # gpg: Signature made Sat 05 Dec 2015 11:42:31 AM PST using RSA key ID 4F8BC9A4 # gpg: requesting key 4F8BC9A4 from hkp server pool.sks-keyservers.net # gpg: no valid OpenPGP data found. # gpg: Total number processed: 0 # gpg: keyserver communications error: key not found # gpg: keyserver communications error: bad public key # gpg: Can't check signature: public key not found # Conflicts: # Makefile.am # NEWS # autogen.sh # configure.ac # doc/Makefile.am # doc/flex.texi # examples/fastwc/mywc.c # lib/Makefile.am # lib/malloc.c # lib/realloc.c # po/POTFILES.in # po/ca.po # po/da.po # po/de.po # po/eo.po # po/es.po # po/fi.po # po/fr.po # po/ga.po # po/hr.po # po/ko.po # po/nl.po # po/pl.po # po/pt_BR.po # po/ro.po # po/ru.po # po/sr.po # po/sv.po # po/tr.po # po/vi.po # po/zh_CN.po # po/zh_TW.po # tests/Makefile.am # tests/README
Diffstat (limited to 'tests/bison_nr_parser.y')
-rw-r--r--tests/bison_nr_parser.y98
1 files changed, 98 insertions, 0 deletions
diff --git a/tests/bison_nr_parser.y b/tests/bison_nr_parser.y
new file mode 100644
index 0000000..3021048
--- /dev/null
+++ b/tests/bison_nr_parser.y
@@ -0,0 +1,98 @@
+/*
+ * This file is part of flex.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+
+/*
+ How to compile:
+ bison --defines --output-file="parser.c" --name-prefix="test" parser.y
+ */
+%{
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include "config.h"
+#include "bison_nr_parser.h"
+#include "bison_nr_scanner.h"
+
+#define YYERROR_VERBOSE 1
+/* #define YYPARSE_PARAM scanner */
+/* #define YYLEX_PARAM scanner */
+
+int yyerror(const char* msg);
+extern int testget_lineno(void);
+
+
+/* A dummy function. A check against seg-faults in yylval->str. */
+int process_text(char* s) {
+ int total =0;
+ while(*s) {
+ total += (int) *s;
+ ++s;
+ }
+ return total;
+}
+
+
+%}
+
+%pure_parser
+
+%union {
+ int lineno;
+ char * str;
+}
+%token <str> IDENT
+%token <lineno> LINENO
+%token EQUAL "="
+%token COLON ":"
+%token SPACE " "
+%%
+
+file:
+ line
+ | file line
+ ;
+
+line:
+ LINENO COLON SPACE IDENT EQUAL IDENT
+ {
+ process_text($4);
+ process_text($6);
+ /* Check lineno. */
+ if( $1 != @1.first_line || $1 != testget_lineno())
+ {
+ yyerror("Parse failed: Line numbers do not match.");
+ YYABORT;
+ }
+
+ /* Recreate the line to stdout. */
+ printf ( "%04d: %s=%s\n", @1.first_line, $4, $6);
+ }
+ ;
+
+%%
+
+int yyerror(const char* msg) {
+ fprintf(stderr,"%s\n",msg);
+ return 0;
+}
+