summaryrefslogtreecommitdiff
path: root/tests/bison_yylval_scanner.l
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-22 13:36:58 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-22 13:36:58 -0800
commit426e91fa66c2a2341d46f977ee351bd24ef3331c (patch)
treeb4d506125335b5e5d748ac284b7239e10df96d21 /tests/bison_yylval_scanner.l
parent26bb2525c89ecda0b0bc7b597ec8d1b792fc8662 (diff)
parent83d5d1695a2ab1d69ea4d8e7df27146c644876fc (diff)
Merge tag 'v2.6.0' into upstream
flex v2.6.0 release Signed-off-by: Manoj Srivastava <srivasta@debian.org> # gpg: Signature made Sat 05 Dec 2015 11:42:31 AM PST using RSA key ID 4F8BC9A4 # gpg: requesting key 4F8BC9A4 from hkp server pool.sks-keyservers.net # gpg: no valid OpenPGP data found. # gpg: Total number processed: 0 # gpg: keyserver communications error: key not found # gpg: keyserver communications error: bad public key # gpg: Can't check signature: public key not found # Conflicts: # Makefile.am # NEWS # autogen.sh # configure.ac # doc/Makefile.am # doc/flex.texi # examples/fastwc/mywc.c # lib/Makefile.am # lib/malloc.c # lib/realloc.c # po/POTFILES.in # po/ca.po # po/da.po # po/de.po # po/eo.po # po/es.po # po/fi.po # po/fr.po # po/ga.po # po/hr.po # po/ko.po # po/nl.po # po/pl.po # po/pt_BR.po # po/ro.po # po/ru.po # po/sr.po # po/sv.po # po/tr.po # po/vi.po # po/zh_CN.po # po/zh_TW.po # tests/Makefile.am # tests/README
Diffstat (limited to 'tests/bison_yylval_scanner.l')
-rw-r--r--tests/bison_yylval_scanner.l81
1 files changed, 81 insertions, 0 deletions
diff --git a/tests/bison_yylval_scanner.l b/tests/bison_yylval_scanner.l
new file mode 100644
index 0000000..db99fa0
--- /dev/null
+++ b/tests/bison_yylval_scanner.l
@@ -0,0 +1,81 @@
+/*
+ * This file is part of flex.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+
+%{
+/* The scanner expects to link to bison yylval . */
+#include <stdio.h>
+#include <stdlib.h>
+#include "bison_yylval_parser.h"
+#include "config.h"
+static char* STRDUP(char* s1);
+
+enum yesno_t { no=0, yes=1 };
+#define YY_EXTRA_TYPE enum yesno_t
+%}
+
+%option 8bit prefix="test"
+%option reentrant bison-bridge
+%option header="bison_yylval_scanner.h"
+%option noyywrap nomain nounput noyy_top_state noyywrap nodefault noinput warn
+%option stack
+
+
+%x IN_TAG
+%x DISCARD_THRU_GT
+%%
+
+ #define YY_USER_INIT yyextra = no;
+ #define NEED_TAG_NAME yyextra
+
+
+<INITIAL>{
+"</" { NEED_TAG_NAME= yes; yy_push_state( IN_TAG, yyscanner); return LTSLASH;}
+"<"[^[:alpha:]] { yy_push_state(DISCARD_THRU_GT,yyscanner); }
+"<" { NEED_TAG_NAME= yes; yy_push_state( IN_TAG, yyscanner); return LT; }
+[^<]{1,512} { yyget_lval(yyscanner)->str = STRDUP(yytext); return TEXT;}
+}
+<IN_TAG>{
+">" { yy_pop_state( yyscanner ); return GT; }
+[[:alpha:]][[:alnum:]]* {
+ if( NEED_TAG_NAME == yes){
+ NEED_TAG_NAME=no;
+ yylval->str = STRDUP(yytext);
+ return TAGNAME;
+ }
+ }
+
+.|\r|\n { }
+}
+<DISCARD_THRU_GT>{
+[^>]{1,512} { }
+">" { yy_pop_state(yyscanner);}
+}
+%%
+
+
+static char* STRDUP(char* s1)
+{
+ char* s2 = (char*)malloc(strlen(s1)+1);
+ sprintf(s2,"%s",s1);
+ return s2;
+}