summaryrefslogtreecommitdiff
path: root/tests/create-test
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-22 13:51:30 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-22 13:51:30 -0800
commitf753f2b7b6d97014110dbe418861353a2f3f445d (patch)
tree7f248ce2f59fbb79cab24b4727955e37e9a5ab81 /tests/create-test
parent306163051847aaaabe7ae0f4cfc7d23f15923f3a (diff)
parenta646b6cd438dc4bd957c6c6afd89b5e8e59468fe (diff)
Merge branch 'upstream'
Signed-off-by: Manoj Srivastava <srivasta@debian.org> # Conflicts: # INSTALL # Makefile.in # aclocal.m4 # build-aux/compile # build-aux/config.guess # build-aux/config.sub # build-aux/depcomp # build-aux/install-sh # build-aux/mdate-sh # build-aux/texinfo.tex # configure # doc/Makefile.in # doc/flex.1 # doc/flex.info # doc/flex.info-1 # doc/flex.info-2 # doc/flex.pdf # doc/stamp-vti # doc/version.texi # examples/Makefile.in # examples/fastwc/Makefile.in # examples/manual/Makefile.in # src/config.h.in # tests/Makefile.in # tests/test-bison-nr/Makefile.am # tests/test-bison-yylloc/Makefile.am # tests/test-bison-yylval/Makefile.am # tools/Makefile.in
Diffstat (limited to 'tests/create-test')
-rwxr-xr-xtests/create-test33
1 files changed, 0 insertions, 33 deletions
diff --git a/tests/create-test b/tests/create-test
deleted file mode 100755
index 05e6864..0000000
--- a/tests/create-test
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-
-TESTFILES="Makefile.am scanner.l parser.y .cvsignore test.input"
-
-if [ ! $# -eq 1 ] ; then
- echo 1>&2 Usage: $0 test-name
- exit 1
-fi
-
-if test -e "$1" ; then
- echo 1>&2 "$1 exists already"
- exit 1
-fi
-
-mkdir $1
-if test "$?" -ne 0 ; then
- echo 1>&2 "mkdir $1 failed"
- exit 1
-fi
-
-for i in $TESTFILES ; do
- cp TEMPLATE/$i $1/$i
-done
-
-echo "$1" >> "$1"/.cvsignore
-
-sed -i '/--new-test-here--/i\
-tests/'"$1"'/Makefile' ../configure.in
-
-sed -i '/^\(DIST_\)\?SUBDIRS/a\
- '"$1"' \\' Makefile.am
-
-sed -i "s:TEMPLATE:$1:g" "$1"/Makefile.am