summaryrefslogtreecommitdiff
path: root/tests/include_by_push.direct.l
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-22 13:36:58 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-22 13:36:58 -0800
commit426e91fa66c2a2341d46f977ee351bd24ef3331c (patch)
treeb4d506125335b5e5d748ac284b7239e10df96d21 /tests/include_by_push.direct.l
parent26bb2525c89ecda0b0bc7b597ec8d1b792fc8662 (diff)
parent83d5d1695a2ab1d69ea4d8e7df27146c644876fc (diff)
Merge tag 'v2.6.0' into upstream
flex v2.6.0 release Signed-off-by: Manoj Srivastava <srivasta@debian.org> # gpg: Signature made Sat 05 Dec 2015 11:42:31 AM PST using RSA key ID 4F8BC9A4 # gpg: requesting key 4F8BC9A4 from hkp server pool.sks-keyservers.net # gpg: no valid OpenPGP data found. # gpg: Total number processed: 0 # gpg: keyserver communications error: key not found # gpg: keyserver communications error: bad public key # gpg: Can't check signature: public key not found # Conflicts: # Makefile.am # NEWS # autogen.sh # configure.ac # doc/Makefile.am # doc/flex.texi # examples/fastwc/mywc.c # lib/Makefile.am # lib/malloc.c # lib/realloc.c # po/POTFILES.in # po/ca.po # po/da.po # po/de.po # po/eo.po # po/es.po # po/fi.po # po/fr.po # po/ga.po # po/hr.po # po/ko.po # po/nl.po # po/pl.po # po/pt_BR.po # po/ro.po # po/ru.po # po/sr.po # po/sv.po # po/tr.po # po/vi.po # po/zh_CN.po # po/zh_TW.po # tests/Makefile.am # tests/README
Diffstat (limited to 'tests/include_by_push.direct.l')
-rw-r--r--tests/include_by_push.direct.l92
1 files changed, 92 insertions, 0 deletions
diff --git a/tests/include_by_push.direct.l b/tests/include_by_push.direct.l
new file mode 100644
index 0000000..6b7a5fa
--- /dev/null
+++ b/tests/include_by_push.direct.l
@@ -0,0 +1,92 @@
+/*
+ * This file is part of flex.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+
+%{
+/* A scanner file to build "scanner.c".
+ Input language is any text.
+ "#include <filename>" causes a buffer switch.
+ */
+#include <stdio.h>
+#include <stdlib.h>
+#include "config.h"
+%}
+
+%option 8bit prefix="test"
+%option nounput nomain noyywrap noinput
+%option warn
+
+%x GET_FILENAME
+
+%%
+
+<INITIAL>{
+^"#include"[[:blank:]]+"<" { BEGIN(GET_FILENAME); }
+.|\n { ECHO; }
+}
+
+<GET_FILENAME>{
+[[:alnum:]_.-]+> {
+ /* recurse */
+ yytext[yyleng-1]='\0';
+ if((yyin=fopen(yytext,"r"))==NULL) {
+ fprintf(stderr,"*** Error: Could not open include file \"%s\".\n",yytext);
+ yyterminate();
+ }
+ yypush_buffer_state( yy_create_buffer( yyin, YY_BUF_SIZE ));
+ BEGIN(0);
+ }
+.|\n {
+ fprintf(stderr,"Invalid input \"%s\".\n", yytext);
+ yyterminate();
+ }
+}
+
+<<EOF>> {
+ fclose(yyin);
+ yypop_buffer_state();
+ if(!YY_CURRENT_BUFFER)
+ yyterminate();
+ }
+
+%%
+
+int main(int argc, char** argv);
+
+int
+main ( int argc, char** argv )
+{
+ FILE * fp;
+ if( argc != 2 ) {
+ fprintf(stderr,"*** Error: Must specify one filename.\n");
+ exit(-1);
+ }
+ if((fp=fopen(argv[1],"r"))==NULL) {
+ fprintf(stderr,"*** Error: fopen(%s) failed.\n",argv[1]);
+ exit(-1);
+ }
+ yyin = fp;
+ yyout = stdout;
+ yylex();
+ printf("TEST RETURNING OK.\n");
+ return 0;
+}