summaryrefslogtreecommitdiff
path: root/tests/multiple_scanners_r_main.c
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-22 13:36:58 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-22 13:36:58 -0800
commit426e91fa66c2a2341d46f977ee351bd24ef3331c (patch)
treeb4d506125335b5e5d748ac284b7239e10df96d21 /tests/multiple_scanners_r_main.c
parent26bb2525c89ecda0b0bc7b597ec8d1b792fc8662 (diff)
parent83d5d1695a2ab1d69ea4d8e7df27146c644876fc (diff)
Merge tag 'v2.6.0' into upstream
flex v2.6.0 release Signed-off-by: Manoj Srivastava <srivasta@debian.org> # gpg: Signature made Sat 05 Dec 2015 11:42:31 AM PST using RSA key ID 4F8BC9A4 # gpg: requesting key 4F8BC9A4 from hkp server pool.sks-keyservers.net # gpg: no valid OpenPGP data found. # gpg: Total number processed: 0 # gpg: keyserver communications error: key not found # gpg: keyserver communications error: bad public key # gpg: Can't check signature: public key not found # Conflicts: # Makefile.am # NEWS # autogen.sh # configure.ac # doc/Makefile.am # doc/flex.texi # examples/fastwc/mywc.c # lib/Makefile.am # lib/malloc.c # lib/realloc.c # po/POTFILES.in # po/ca.po # po/da.po # po/de.po # po/eo.po # po/es.po # po/fi.po # po/fr.po # po/ga.po # po/hr.po # po/ko.po # po/nl.po # po/pl.po # po/pt_BR.po # po/ro.po # po/ru.po # po/sr.po # po/sv.po # po/tr.po # po/vi.po # po/zh_CN.po # po/zh_TW.po # tests/Makefile.am # tests/README
Diffstat (limited to 'tests/multiple_scanners_r_main.c')
-rw-r--r--tests/multiple_scanners_r_main.c65
1 files changed, 65 insertions, 0 deletions
diff --git a/tests/multiple_scanners_r_main.c b/tests/multiple_scanners_r_main.c
new file mode 100644
index 0000000..ea73806
--- /dev/null
+++ b/tests/multiple_scanners_r_main.c
@@ -0,0 +1,65 @@
+/*
+ * This file is part of flex.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+
+#include "multiple_scanners_r_1.h"
+#include "multiple_scanners_r_2.h"
+
+int
+main ( int argc, char** argv )
+{
+ (void)argc;
+ (void)argv;
+
+ int S1_ok=1, S2_ok=1;
+ FILE * fp;
+ YY_BUFFER_STATE buff1, buff2;
+ yyscan_t scan1, scan2;
+
+ S1_lex_init(&scan1);
+ S2_lex_init(&scan2);
+
+ S1_set_out(stdout,scan1);
+ S2_set_out(S1_get_out(scan1),scan2);
+
+ buff1 = S1__scan_string("foo on bar off", scan1);
+ buff2 = S2__scan_string("on blah blah off foo on bar off", scan2);
+
+ /* scan simultaneously. */
+ while(S1_ok || S2_ok)
+ {
+ if (S1_ok)
+ S1_ok = S1_lex(scan1);
+ if (S2_ok)
+ S2_ok = S2_lex(scan2);
+ }
+ S1__delete_buffer(buff1, scan1);
+ S2__delete_buffer(buff2, scan2);
+
+ S1_lex_destroy(scan1);
+ S2_lex_destroy(scan2);
+ printf("TEST RETURNING OK.\n");
+ return 0;
+}
+
+
+/* vim:set tabstop=8 softtabstop=4 shiftwidth=4: */