summaryrefslogtreecommitdiff
path: root/tests/posixly_correct.l
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-22 13:51:30 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-22 13:51:30 -0800
commitf753f2b7b6d97014110dbe418861353a2f3f445d (patch)
tree7f248ce2f59fbb79cab24b4727955e37e9a5ab81 /tests/posixly_correct.l
parent306163051847aaaabe7ae0f4cfc7d23f15923f3a (diff)
parenta646b6cd438dc4bd957c6c6afd89b5e8e59468fe (diff)
Merge branch 'upstream'
Signed-off-by: Manoj Srivastava <srivasta@debian.org> # Conflicts: # INSTALL # Makefile.in # aclocal.m4 # build-aux/compile # build-aux/config.guess # build-aux/config.sub # build-aux/depcomp # build-aux/install-sh # build-aux/mdate-sh # build-aux/texinfo.tex # configure # doc/Makefile.in # doc/flex.1 # doc/flex.info # doc/flex.info-1 # doc/flex.info-2 # doc/flex.pdf # doc/stamp-vti # doc/version.texi # examples/Makefile.in # examples/fastwc/Makefile.in # examples/manual/Makefile.in # src/config.h.in # tests/Makefile.in # tests/test-bison-nr/Makefile.am # tests/test-bison-yylloc/Makefile.am # tests/test-bison-yylval/Makefile.am # tools/Makefile.in
Diffstat (limited to 'tests/posixly_correct.l')
-rw-r--r--tests/posixly_correct.l79
1 files changed, 79 insertions, 0 deletions
diff --git a/tests/posixly_correct.l b/tests/posixly_correct.l
new file mode 100644
index 0000000..aff9cbd
--- /dev/null
+++ b/tests/posixly_correct.l
@@ -0,0 +1,79 @@
+/*
+ * This file is part of flex.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+
+%{
+/* The goal of this test is to verify that we are getting the counter-intuitive
+ * posix behavior of the repeat operator `{}'.
+ *
+ * ab{3} - In traditional flex, this matches "abbb".
+ * In posix, this matches "ababab".
+ */
+#include <stdio.h>
+#include <stdlib.h>
+#include "config.h"
+
+#define NUM_TESTS 1
+char * tests[NUM_TESTS] = { "ababab"};
+int main(void);
+
+int tests_ok[NUM_TESTS] = { 0 };
+
+%}
+
+%option 8bit prefix="test"
+%option nounput nomain noyywrap noinput
+%option warn
+
+
+%%
+
+ab{3} tests_ok[0] = 1; return 0;
+.|\n return 0;
+
+%%
+
+
+int main ()
+{
+ YY_BUFFER_STATE state;
+ int i;
+
+ yyin = stdin;
+ yyout = stdout;
+
+ /* Run the tests */
+ for (i=0; i < NUM_TESTS; i++){
+ printf("Testing: yy_scan_string(%s): ", tests[i]);
+ state = yy_scan_string(tests[i]);
+ yylex();
+ yy_delete_buffer(state);
+ printf("... %s\n", tests_ok[i] ? "OK" : "FAILED");
+ }
+
+ for (i=0; i < NUM_TESTS; i++)
+ if (!tests_ok[i])
+ exit(1);
+
+ printf("TEST RETURNING OK.\n");
+ return 0;
+}