summaryrefslogtreecommitdiff
path: root/tests/tableopts.l4
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-22 13:51:30 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-22 13:51:30 -0800
commitf753f2b7b6d97014110dbe418861353a2f3f445d (patch)
tree7f248ce2f59fbb79cab24b4727955e37e9a5ab81 /tests/tableopts.l4
parent306163051847aaaabe7ae0f4cfc7d23f15923f3a (diff)
parenta646b6cd438dc4bd957c6c6afd89b5e8e59468fe (diff)
Merge branch 'upstream'
Signed-off-by: Manoj Srivastava <srivasta@debian.org> # Conflicts: # INSTALL # Makefile.in # aclocal.m4 # build-aux/compile # build-aux/config.guess # build-aux/config.sub # build-aux/depcomp # build-aux/install-sh # build-aux/mdate-sh # build-aux/texinfo.tex # configure # doc/Makefile.in # doc/flex.1 # doc/flex.info # doc/flex.info-1 # doc/flex.info-2 # doc/flex.pdf # doc/stamp-vti # doc/version.texi # examples/Makefile.in # examples/fastwc/Makefile.in # examples/manual/Makefile.in # src/config.h.in # tests/Makefile.in # tests/test-bison-nr/Makefile.am # tests/test-bison-yylloc/Makefile.am # tests/test-bison-yylval/Makefile.am # tools/Makefile.in
Diffstat (limited to 'tests/tableopts.l4')
-rw-r--r--tests/tableopts.l484
1 files changed, 84 insertions, 0 deletions
diff --git a/tests/tableopts.l4 b/tests/tableopts.l4
new file mode 100644
index 0000000..bb79407
--- /dev/null
+++ b/tests/tableopts.l4
@@ -0,0 +1,84 @@
+/*
+ * This file is part of flex.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+
+%{
+/* A template scanner file to build "scanner.c". */
+#include <stdio.h>
+#include <stdlib.h>
+#include "config.h"
+%}
+
+%option 8bit
+%option nounput nomain noyywrap noinput
+%option warn yylineno
+
+
+
+%%
+
+foo|bar ;
+[[:digit:]]+ ;
+[[:blank:]]+ ;
+.|\n ;
+%%
+
+int main ( int argc, char** argv )
+{
+ FILE* fp = NULL;
+ void *yyscanner=0;
+ M4_YY_DECL_GUTS_VAR();
+
+#ifdef TEST_IS_REENTRANT
+ yylex_init(&yyscanner);
+#else
+ (void)yyscanner;
+#endif
+
+#ifdef TEST_HAS_TABLES_EXTERNAL
+ if((fp = fopen(argv[1],"r"))== NULL)
+ YY_FATAL_ERROR("could not open tables file for reading");
+
+ if(yytables_fload(fp M4_YY_CALL_LAST_ARG) < 0)
+ YY_FATAL_ERROR("yytables_fload returned < 0");
+ if(M4_YY_TABLES_VERIFY)
+ exit(0);
+#endif
+
+ if(argc > 2){
+ if((fp = fopen(argv[2],"r"))== NULL)
+ YY_FATAL_ERROR("could not open input file for reading");
+ yyin = fp;
+ }
+ while(yylex(M4_YY_CALL_ONLY_ARG) != 0)
+ ;
+
+#ifdef TEST_HAS_TABLES_EXTERNAL
+ yytables_destroy(M4_YY_CALL_ONLY_ARG);
+#endif
+ yylex_destroy(M4_YY_CALL_ONLY_ARG);
+
+ if(argc < 0) /* silence the compiler */
+ yyscanner = (void*)fp;
+
+ return 0;
+}