summaryrefslogtreecommitdiff
path: root/tests/tableopts.sh
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-07-17 21:36:43 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:28 -0500
commit5336a9063d15fdeb086aef060754dd32abce6cba (patch)
tree9fbb41226bed2f8eb0eea835dc0bfd292165531a /tests/tableopts.sh
parent2c64f2fa80772cd681f4c358e651accd7868552c (diff)
add tableopts.sh script
Diffstat (limited to 'tests/tableopts.sh')
-rwxr-xr-xtests/tableopts.sh34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/tableopts.sh b/tests/tableopts.sh
new file mode 100755
index 0000000..eada259
--- /dev/null
+++ b/tests/tableopts.sh
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+# This script is present to generate the automake _SOURCES variables
+# for the tableopts_* tests. It also generates the linking rules for
+# each test since automake isn't able to handle the pattern rules that
+# would be natural to use. Output is written to standard output for
+# inclusion in a Makefile.am, typically by redirecting the output and then an automake include directive.
+
+for kind in opt ser ver ; do
+for threading in nr r ; do
+for opt in -Ca -Ce -Cf -CF -Cm -Cem -Cae -Caef -CaeF -Cam -Caem ; do
+ testname=tableopts_${kind}_${threading}${opt}.${kind}
+ if [ "${TABLEOPTS_TESTS}" = "" ] ;then
+ TABLEOPTS_TESTS=${testname}
+ tableopts_tables=${testname}.tables
+ else
+ TABLEOPTS_TESTS="${TABLEOPTS_TESTS} ${testname}"
+ tableopts_tables="${tableopts_tables} ${testname}.tables"
+ fi
+ bare_opt=${opt#-}
+ cat << EOF
+tableopts_${kind}_${threading}_${bare_opt}_${kind}_SOURCES = tableopts.l4
+
+${testname}\$(EXEEXT): tableopts_${kind}_${threading}${opt}.\$(OBJEXT)
+ \$(LINK) -o \$@ \$<
+
+EOF
+done
+done
+done
+
+echo TABLEOPTS_TESTS = ${TABLEOPTS_TESTS}
+echo
+echo tableopts_tables = ${tableopts_tables}