summaryrefslogtreecommitdiff
path: root/tests/tableopts.sh
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-07-18 17:41:23 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:28 -0500
commit976cc15cf72c08521e4b575cad6900c109ca71b2 (patch)
tree278d0d736a4b0475aac5d595a69e30953df64e61 /tests/tableopts.sh
parent5336a9063d15fdeb086aef060754dd32abce6cba (diff)
split apart table options tests into tests per threading, table option, serialization and verification
Diffstat (limited to 'tests/tableopts.sh')
-rwxr-xr-xtests/tableopts.sh33
1 files changed, 19 insertions, 14 deletions
diff --git a/tests/tableopts.sh b/tests/tableopts.sh
index eada259..f009b7d 100755
--- a/tests/tableopts.sh
+++ b/tests/tableopts.sh
@@ -7,26 +7,31 @@
# inclusion in a Makefile.am, typically by redirecting the output and then an automake include directive.
for kind in opt ser ver ; do
-for threading in nr r ; do
-for opt in -Ca -Ce -Cf -CF -Cm -Cem -Cae -Caef -CaeF -Cam -Caem ; do
- testname=tableopts_${kind}_${threading}${opt}.${kind}
- if [ "${TABLEOPTS_TESTS}" = "" ] ;then
- TABLEOPTS_TESTS=${testname}
- tableopts_tables=${testname}.tables
- else
- TABLEOPTS_TESTS="${TABLEOPTS_TESTS} ${testname}"
- tableopts_tables="${tableopts_tables} ${testname}.tables"
- fi
- bare_opt=${opt#-}
- cat << EOF
+ for threading in nr r ; do
+ for opt in -Ca -Ce -Cf -CF -Cm -Cem -Cae -Caef -CaeF -Cam -Caem ; do
+ testname=tableopts_${kind}_${threading}${opt}.${kind}
+ if [ "${TABLEOPTS_TESTS}" = "" ] ;then
+ TABLEOPTS_TESTS=${testname}
+ if [ "$kind" = "ser" -o "$kind" = "ver" ] ; then
+ tableopts_tables=${testname}.tables
+ fi
+ else
+ TABLEOPTS_TESTS="${TABLEOPTS_TESTS} ${testname}"
+ if [ "$kind" = "ser" -o "$kind" = "ver" ] ; then
+ tableopts_tables="${tableopts_tables} ${testname}.tables"
+ fi
+ fi
+
+ bare_opt=${opt#-}
+ cat << EOF
tableopts_${kind}_${threading}_${bare_opt}_${kind}_SOURCES = tableopts.l4
${testname}\$(EXEEXT): tableopts_${kind}_${threading}${opt}.\$(OBJEXT)
\$(LINK) -o \$@ \$<
EOF
-done
-done
+ done
+ done
done
echo TABLEOPTS_TESTS = ${TABLEOPTS_TESTS}