summaryrefslogtreecommitdiff
path: root/tests/tableopts.sh
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-07-18 21:16:11 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:28 -0500
commitf4ec87b6d926cfe635b480dbeec71b3b489dbb02 (patch)
tree3fade66a004ff0f861fa2bd3b2846bc0febd27ea /tests/tableopts.sh
parent976cc15cf72c08521e4b575cad6900c109ca71b2 (diff)
use unofficial bash strict mode and cleanups in supporting bash scripts
Diffstat (limited to 'tests/tableopts.sh')
-rwxr-xr-xtests/tableopts.sh7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/tableopts.sh b/tests/tableopts.sh
index f009b7d..63a36d3 100755
--- a/tests/tableopts.sh
+++ b/tests/tableopts.sh
@@ -1,4 +1,6 @@
-#!/bin/sh
+#!/bin/bash
+set -euo pipefail
+IFS=$'\n\t'
# This script is present to generate the automake _SOURCES variables
# for the tableopts_* tests. It also generates the linking rules for
@@ -6,6 +8,9 @@
# would be natural to use. Output is written to standard output for
# inclusion in a Makefile.am, typically by redirecting the output and then an automake include directive.
+TABLEOPTS_TESTS=""
+tableopts_tables=""
+
for kind in opt ser ver ; do
for threading in nr r ; do
for opt in -Ca -Ce -Cf -CF -Cm -Cem -Cae -Caef -CaeF -Cam -Caem ; do