summaryrefslogtreecommitdiff
path: root/tests/test-bison-yylloc/Makefile.am
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-04-09 00:15:48 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-04-09 00:15:48 -0700
commit26bb2525c89ecda0b0bc7b597ec8d1b792fc8662 (patch)
treeb2ecc519218e259a4fb5e5f0a72b7e00bc3a2b43 /tests/test-bison-yylloc/Makefile.am
parentada7779d8b7a39d01dd70d733883db2383e61a6e (diff)
Imported Upstream version 2.5.39
Diffstat (limited to 'tests/test-bison-yylloc/Makefile.am')
-rw-r--r--tests/test-bison-yylloc/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/tests/test-bison-yylloc/Makefile.am b/tests/test-bison-yylloc/Makefile.am
index 3be8907..dc41b0f 100644
--- a/tests/test-bison-yylloc/Makefile.am
+++ b/tests/test-bison-yylloc/Makefile.am
@@ -36,18 +36,20 @@ testname = test-bison-yylloc
scanner.c: $(srcdir)/scanner.l
$(FLEX) $<
+scanner.h: scanner.c
+scanner.o: parser.h
parser.c: $(srcdir)/parser.y
$(BISON) $(YFLAGS) $<
+parser.h: parser.c
+
+main.o: scanner.h parser.h
$(testname)$(EXEEXT): $(OBJS)
- $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
+ $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
test: $(testname)$(EXEEXT)
./$(testname)$(EXEEXT) < $(srcdir)/test.input
.c.o:
$(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
-
-parser.h: parser.c
-scanner.c main.o: parser.h